Microsoft Excel

Herbers Excel/VBA-Archiv

Register alle auf 1. Tabellenblatt | Herbers Excel-Forum


Betrifft: Register alle auf 1. Tabellenblatt von: Dänu
Geschrieben am: 18.12.2009 21:15:50

Hoizäme
Ich führe eine Baukontrolle über div.Projekte. Jedes Projekt in der Arbeitsmappe belegt ein einzelnes Arbeitsblatt dessen Registernamen der Name des Projekts ist.
Ich möchte ein Deckblatt mit den Registernamen untereinander erstellen, um dahinter mittels Zellbezügen zu den jeweiligen Blättern eine Übersicht über die jeweiligen Kostenstände erstellen zu können.
Besteht eine einfache Art, die Registernamen jeweils beim Aufstarten automatisiert auf dieser Übersicht zu erhalten?

  

Betrifft: AW: Register alle auf 1. Tabellenblatt von: Hajo_Zi
Geschrieben am: 18.12.2009 21:19:49

Gallo Dänu,


vorhandene Tabellen

 AB
2Tabelle1!a1 
3Tabelle2!a1 
4Webabfrage!a1 
5!a1 
6   
7  Hi Holger,
8   
9  hatte diese Frage auch grad in einem anderen Forum (anderer Fragesteller) so beantwortet:
10   
11  Einfügen -> Namen -> Definieren/Festlegen, Name: x
12  bezieht sich auf:
13  =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())
14   
15  In irgendeine Zelle jetzt diese Formel und runterkopieren:
16  =WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))
17   
18  Grüße Boris
19   
20   
21  Formel runter ziehen falls Mehr Tabellen

verwendete Formeln
Zelle Formel
A2 =HYPERLINK("#" & WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31)) & "!A1";WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))&"!a1" )
A3 =HYPERLINK("#" & WENN(ZEILEN($1:2)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:2));FINDEN("]";INDEX(x;ZEILEN($1:2)))+1;31)) & "!A1";WENN(ZEILEN($1:2)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:2));FINDEN("]";INDEX(x;ZEILEN($1:2)))+1;31))&"!a1" )
A4 =HYPERLINK("#" & WENN(ZEILEN($1:3)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:3));FINDEN("]";INDEX(x;ZEILEN($1:3)))+1;31)) & "!A1";WENN(ZEILEN($1:3)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:3));FINDEN("]";INDEX(x;ZEILEN($1:3)))+1;31))&"!a1" )
B4 =WENN(ISTFEHLER(INDIREKT(A4&"!B4:D4"));"";INDIREKT(A4&"!B4:D4"))
A5 =HYPERLINK("#" & WENN(ZEILEN($1:4)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:4));FINDEN("]";INDEX(x;ZEILEN($1:4)))+1;31)) & "!A1";WENN(ZEILEN($1:4)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:4));FINDEN("]";INDEX(x;ZEILEN($1:4)))+1;31))&"!a1" )
B5 =WENN(ISTFEHLER(INDIREKT(A5&"!B4:D4"));"";INDIREKT(A5&"!B4:D4"))
A6 =HYPERLINK("#" & WENN(ZEILEN($1:5)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:5));FINDEN("]";INDEX(x;ZEILEN($1:5)))+1;31)) & "A1";WENN(ZEILEN($1:5)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:5));FINDEN("]";INDEX(x;ZEILEN($1:5)))+1;31)) )
B6 =WENN(ISTFEHLER(INDIREKT(A6&"!B4:D4"));"";INDIREKT(A6&"!B4:D4"))
A19 =WENN(ZEILEN($1:18)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:18));FINDEN("]";INDEX(x;ZEILEN($1:18)))+1;31))
B19 =WENN(ISTFEHLER(INDIREKT(A19&"!B4:D4"));"";INDIREKT(A19&"!B4:D4"))
A20 =WENN(ZEILEN($1:19)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:19));FINDEN("]";INDEX(x;ZEILEN($1:19)))+1;31))
B20 =WENN(ISTFEHLER(INDIREKT(A20&"!B4:D4"));"";INDIREKT(A20&"!B4:D4"))
A21 =WENN(ZEILEN($1:20)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:20));FINDEN("]";INDEX(x;ZEILEN($1:20)))+1;31))

definierte Namen
Name Bezieht sich auf Tabelle Z1S1-Formel
x=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT()) =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())

Tabellendarstellung in Foren Version 5.1



GrußformelHomepage


  

Betrifft: AW: Register alle auf 1. Tabellenblatt von: Dänu
Geschrieben am: 21.12.2009 16:43:14

Vielen Dank für die Formeln - ich gebe sie ein:

in A1: Die Formel: =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())~f~
in A2: die Formel: ~f~=WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))~f~
ich benenne A1 als "X" mit "Einfügen-Namen-Einfügen"

... und erhalte "Wert"

Ich finde die Formel: ~f~= Arbeitsmappe.zuordnen... nicht in den verfügbaren Formeln.
Wenn ich vor dem "=" ein "Backspace" eingebe - um eine ev. versteckte Formatierung zu löschen - erhalte ich automatisch die Nachricht, dass diese Formel nicht verfügbar sei.

... was mache ich falsch?


  

Betrifft: AW: Register alle auf 1. Tabellenblatt von: Dänu
Geschrieben am: 22.12.2009 08:31:07

... ich sehe nach irre viel Versuchen, und der Prüfung meiner Eingabe, dass ich natürlich A1 mit "Einfügen-Namen-Definieren" den Namen "X" gegeben habe.

Mittlerweile habe ich auch die gesamten Formeln einzeln eingegeben (Copy Paste zuerst, dann manuell) aber irgendwie erhalte ich anstelle der Namen in den Feldern A3, A4, A5 und B4 die Resultate !a1 und dann alles leer...
Ich habe folgendes eingetragen:
in A1: =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())~f~
in A2-A21 die Formeln wie im oberen Raster eingetragen
in B4-B20 die Formeln wie im oberen Raster eingetragen
in H2-H21: ~f~=WENN(ZEILEN($2:2)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($2:2));FINDEN("]";INDEX(x;ZEILEN($2:2)))+1;31))

... bin etwas unglücklich und weiss nicht mehr, wie ich weiter fahren kann - Kann mir nochmals jemand helfen?


  

Betrifft: AW: Register alle auf 1. Tabellenblatt von: Dänu
Geschrieben am: 22.12.2009 15:17:05

Hier anbei ein Beispiel für meine Suche... nach den Namen der Register auf dem 1. Tabellenblatt der Arbeitsmappe

https://www.herber.de/bbs/user/66776.xls


  

Betrifft: AW: Register alle auf 1. Tabellenblatt von: Hajo_Zi
Geschrieben am: 22.12.2009 19:29:12

Hallo Unbekannter,

und noch ein Tip, falls Du auf die Anwort antwortest und nicht auf Deine Frage, sieht man gleich beim Aufruf der Benachrichtung, das der Beitrag auf seine Antwort ist.

Gruß Hajo


  

Betrifft: was mache ich falsch? von: Erich G.
Geschrieben am: 22.12.2009 17:29:26

Hallo Dänu (wenn das dein Vorname ist, soll das eine Anrede sein),

1. Fehler:
Wenn du deine Beiträge mit einer Anrede beginnst und mit einem Gruß beendest,
bekommst du mehr und/oder ausführlichere Antworten.
Das gibts hier noch dazu:


2. Fehler:
Niemand hat geschrieben, dass A1 (oder die Zeile 1) den Namen x bekommen soll.
Hajo hat beschrieben, wie der Name x definiert werden soll.
Statt
=Übersicht!$1:$1
sollte da stehen
=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())

Die (ohnehin unmögliche) Formel in A1 kannst du löschen.

Nebenbemerkung:
x finde ich als Namen zwar schön kurz, aber auch sehr gefährlich,
denn x ist nun mal auch der Name einer Tabellenspalte.

Um mögliche unnötige Probleme gleich zu vermeiden, würde ich x ersetzen durch einen unverwechselbaren Namen.

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort (Dies ist ein Gruß!)

P.S.: Hast du die Checkbox "Frage noch offen" inzwischen gefunden? Ich ja.


  

Betrifft: AW: Register alle auf 1. Tabellenblatt von: Dänu
Geschrieben am: 23.12.2009 16:57:49

Guten Abend Erich und Hajo
Besten Dank für die Einführung in die Etikette eines Forums. Ich wollte meinen Einstand keineswegs als Rüpell geben - ist mir ja voll gelungen - werde mich bessern und die Cyber-Ohrfeigen beherzigen ;-)
Herzlichen Dank für Eure Hilfe. Ich kann aktuell nicht damit arbeiten, werde aber umgehend Bescheid geben - voraussichtlich in der kommenden Woche - ob alles so funktioniert, wie es sollte...
Frohe Weihnacht und besten Gruss
Dänu (Berndeutsche Kurzform v. Daniel...)


  

Betrifft: Danke, alles klar! :-)) von: Erich G.
Geschrieben am: 23.12.2009 18:18:55

Hi Dänu,
danke für deine Zwischenmeldung!
"Cyber-Ohrfeigen" ist nett - das sollten aber keine sein, nur leichte Cyber-Kopfnüsse... ;-)

Auch dir fröhliche Feiertage!

Wenn danach doch noch nicht alles klar ist: Melde dich!

Weihnachtliche Grüße von Erich aus Kamp-Lintfort


Beiträge aus den Excel-Beispielen zum Thema "Register alle auf 1. Tabellenblatt"