Microsoft Excel

Herbers Excel/VBA-Archiv

gleiche Zusammenzählen | Herbers Excel-Forum


Betrifft: gleiche Zusammenzählen von: Susann
Geschrieben am: 29.12.2009 19:19:21

Hallo,

ich habe eine etliche Liste und da sind Artikelnummern drin. Jetzt möchte ich gern, dass die Anzahl der Artikel, wenn diese gleich sind, zusammengezählt wird. Wie mache ich das?

Beispiel:

99046341 1
99103165 1
99046341 3

Soll dann:

99046341 4
99103165 1

Geht das irgendwie? Oder ich müsste wissen, wie man das macht, wenn man die zählenwenn-Funktion nimmt, er beide auf Wahr kennzeichnet. Dann kann ich die Liste nach Wahr sortieren. Wäre auch schon mal eine Erleichterung.

Vielen lieben Dank
Susann

  

Betrifft: AW: gleiche Zusammenzählen von: Hajo_Zi
Geschrieben am: 29.12.2009 19:23:24

Hallo Susan,

Summewenn() falls eine Menge gezählt werden soll.
Zählenwenn() falls Anzahl

GrußformelHomepage


  

Betrifft: AW: gleiche Zusammenzählen von: Susann
Geschrieben am: 29.12.2009 19:25:22

Sorry Hajo,

kannst du mir das etwas genauer erklären? Ich bin da nicht so fit drin. Vielen, vielen lieben Dank


  

Betrifft: AW: gleiche Zusammenzählen von: Hajo_Zi
Geschrieben am: 29.12.2009 19:37:02

Hallo Susann,

Excel hat auch eine Hilfe.

Tabelle1 (2)

 ADAE
18Anzahl Artikel13
19Summe Artikel112
20Artikel11
21Artikel22
22Artikel33
23Artikel14
24Artikel25
25Artikel36
26Artikel17
27Artikel28
28Artikel39
29v10

verwendete Formeln
Zelle Formel
AE18 =ZÄHLENWENN(AD20:AD29;"Artikel1")
AE19 =SUMMEWENN(AD20:AD29;"Artikel1";AE20:AE29)

Tabellendarstellung in Foren Version 5.3



Gruß Hajo


  

Betrifft: AW: @ Hajo von: hary
Geschrieben am: 29.12.2009 19:26:57

Hallo Hajo
schaust Du mal bitte in den Thread weiter unter Uhrzeit mit Komma.
geht um Deinen Code. Ich bekomme den Fehler nicht raus.
https://www.herber.de/forum/messages/1126272.html
gruss hary


  

Betrifft: mit Summewenn() von: Matthias L
Geschrieben am: 29.12.2009 19:28:27

Hallo




  

Betrifft: klappt, danke schön von: Susann
Geschrieben am: 29.12.2009 19:34:31




Beiträge aus den Excel-Beispielen zum Thema "gleiche Zusammenzählen"