Microsoft Excel

Herbers Excel/VBA-Archiv

Rang bei gleichem Punktestand | Herbers Excel-Forum


Betrifft: Rang bei gleichem Punktestand von: Sebastian
Geschrieben am: 09.01.2010 21:57:49

Hallo,

ich habe ein kleines Problem und bitte um Eure Hilfe.

Ich versuche eine Rangliste zu erstellen. Dies hat mit der Funktion RANG auch soweit geklappt. Nun stellt sich aber folgendes Problem da: Bei gleichem Punktestand der erste Rang mehrmals Angezeigt wird. Da Spieler 1 aber öffters den 1 Platz gemacht hat suche ich eine Funktion/Formel die beides berücksichtigt.

Eine Beispieldatei liegt auf dem Server.

https://www.herber.de/bbs/user/67106.xls

Vielen Dank für Eure Hilfe und ein schönes Wochenende.

Gruß

Sebastian

  

Betrifft: AW: Rang bei gleichem Punktestand von: Josef Ehrensberger
Geschrieben am: 09.01.2010 22:00:30

Hallo Sebastian,

guckst du hier: http://www.excelformeln.de/formeln.html?welcher=137


Gruß Sepp



  

Betrifft: AW: Rang bei gleichem Punktestand von: Sebastian
Geschrieben am: 09.01.2010 22:05:21

Hallo Sepp,

gute Sache, das Problem ist nur das die Name nicht sortiert werden sollen.

Gruß
Sebastian


  

Betrifft: AW: Rang bei gleichem Punktestand von: Peter
Geschrieben am: 09.01.2010 22:31:27

Hallo Sebastian
Dann ist gibt es also noch eine zweite Gewichtung, nebst Rang 1 = 10 Punkte, Rang 2 = 8 Punkte, ect.
Welche?

Gruss, Peter

=ZÄHLENWENN(C2:H2;1)*10+ZÄHLENWENN(C2:H2;2)*8+ZÄHLENWENN(C2:H2;3)*6+ZÄHLENWENN(C2:H2;4) *5+ZÄHLENWENN(C2:H2;5)*4+ZÄHLENWENN(C2:H2;6)*3+ZÄHLENWENN(C2:H2;7)*2+ZÄHLENWENN(C2:H2;8) *1


  

Betrifft: AW: Rang bei gleichem Punktestand von: Josef Ehrensberger
Geschrieben am: 09.01.2010 22:33:44

Hallo Sebastian,

dann probier mal so.

Tabelle1

 CDEFGHIJK
101.01.201008.01.201015.01.201022.01.201029.01.201005.02.2010PunkteRangSpieler
2111199401Seppel
3222246402Chris

Formeln der Tabelle
ZelleFormel
I2{=SUMME(ZÄHLENWENN(C2:H2;ZEILE($1:$8))*{10;8;6;5;4;3;2;1})+SUMME(WENN(C2:H2<=8;-C2:H2*10^-6))}
J2=RANG(I2;$I$2:$I$27;0)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
J21. / Zellwert ist gleich ="A"Abc
J22. / Zellwert ist gleich 3Abc
J23. / Zellwert ist gleich 2Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: Korrektur! von: Josef Ehrensberger
Geschrieben am: 09.01.2010 22:40:28

Hallo nochmal,

da ist mir ein minus reingerutscht.

Tabelle1

 CDEFGHIJK
101.01.201008.01.201015.01.201022.01.201029.01.201005.02.2010PunkteRangSpieler
2111199402Seppel
3222246401Chris

Formeln der Tabelle
ZelleFormel
I2{=SUMME(ZÄHLENWENN(C2:H2;ZEILE($1:$8))*{10;8;6;5;4;3;2;1})+SUMME(WENN(C2:H2<=8;C2:H2*10^-6))}
J2=RANG(I2;$I$2:$I$27;0)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
J21. / Zellwert ist gleich ="A"Abc
J22. / Zellwert ist gleich 3Abc
J23. / Zellwert ist gleich 2Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: Sch*** Alk, das Minus passt schon so! o.T. von: Josef Ehrensberger
Geschrieben am: 09.01.2010 22:51:33

Gruß Sepp



  

Betrifft: AW: das passt leider noch nicht von: Sebastian
Geschrieben am: 10.01.2010 01:38:11

Hallo Sepp,

das passt leider noch nicht ganz. Ausschlaggebend für den Rang sind die erspielten Punkte, bei Punktegleichstand sind dann die Anzahl der erst Platzierungen ausschlaggebend.
Hier noch mal die Datei mit einer Erläuterung wie das Ergebnis an Ende aussehen soll.
https://www.herber.de/bbs/user/67107.xls

Vielen vielen Dank für die Hilfe,

Gruß

Sebastian


  

Betrifft: AW: das passt leider noch nicht von: Josef Ehrensberger
Geschrieben am: 10.01.2010 02:54:43

Hallo Sebastian,

aber jetzt sollte es endgültig passen.

Tabelle2

 CDEFGHIJK
101.01.201008.01.201015.01.201022.01.201029.01.201005.02.2010PunkteRangSpieler
2111189411Seppel
3222326414Chris
4261119412Max
5216225413Tina

Formeln der Tabelle
ZelleFormel
I2{=SUMME(ZÄHLENWENN(C2:H2;ZEILE($1:$8))*{10;8;6;5;4;3;2;1})+SUMME(ZÄHLENWENN(C2:H2;ZEILE($1:$8))*10^-ZEILE($2:$9))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Vielen Dank von: Sebastian
Geschrieben am: 10.01.2010 13:12:55

Ja, super,

vielen Dank.


  

Betrifft: AW: das passt leider noch nicht von: Peter
Geschrieben am: 11.01.2010 09:55:54

Hallo
Weshalb ergibt diese Formel die richtige Reihenfolge - bezieht sich doch die Formel nur auf Spalte I und in dieser steht auf allen 4 Zeilen 41 ?
=RANG(I2;$I$2:$I$27;0)
Gruss, Peter


  

Betrifft: AW: das passt leider noch nicht von: Josef Ehrensberger
Geschrieben am: 11.01.2010 11:29:00

Hallo Peter,

formatiere die Spalte I mal mit mehreren Kommastellen, dann siehst du den Unterschied.


Gruß Sepp



  

Betrifft: AW: das passt leider noch nicht von: Peter
Geschrieben am: 11.01.2010 14:12:52

Hallo Sepp
Auf die Idee war ich auch schon gekommen - allerdings beliess ich es bei 1 Nachkommastelle ;-)
Vielen Dank und Gruss, Peter