Herbers Excel-Forum - das Archiv

Zeilen löschen



Excel-Version: 2000
nach unten

Betrifft: Zeilen löschen
von: Jürgen


Geschrieben am: 26.04.2002 - 11:05:22

Hallo alle zusammen,

ich habe folgendes Problem:

Ich habe eine Tabelle mit über 1000 Datensätzen. Die Datensätze sind zuerst nach Artikel und innerhalb des Artikels dann nach Datum von alt nach neu sortiert. Ich möchte mir nun zu jedem Artikel die zwei neuesten Datensätze anzeigen lassen.

Die restlichen den jeweiligen Artikel betreffenden Zeilen möchte ich automatisch löschen.

Kann mir dabei jemand helfen?

Im voraus schon mal

Danke,

Jürgen.

nach oben   nach unten

Re: Zeilen löschen
von: Coach


Geschrieben am: 26.04.2002 - 11:21:12

Hallo Jürgen, versuchen wir es mal hier (inzwischen steht die Antwort auch in dem Forum). Arrayformel: =WENN(B2_KGRÖSSTE(WENN($A$2:$A$1000=A2;$B$2:$B$1000);2);"Y";"N") Das _ in der Formel durch ein < ersetzen (sonst funktioniert bizarrer Weise die Übernahme ins Forum nicht). Dann händisch Filter oder per VBA alle Y löschen. Gruß Coach

nach oben   nach unten

Re: Zeilen löschen
von: Jürgen
Geschrieben am: 26.04.2002 - 13:06:24

Danke Coach, ich versuche es mal. Gruss, Jürgen

 nach oben

Excel-Beispiele zum Thema "Zeilen löschen"
Zeilenhöhe in cm festlegen Summe gefilterter Zeilen
Zeilenumbruch Leere Zeilen löschen
Spalten/Zeilen aus- und einblenden Zeilenumbruch in Formel erzwingen
Zeilen und Spalten über ein Drehfeld ein- und ausblenden Alle Kopf-/Fußzeilen-Festlegungen löschen
Fußzeilen beim Öffnen eintragen Zellinhalte zeilenweise sortieren