Vergleich von Werten



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Vergleich von Werten
von: Michael
Geschrieben am: 15.05.2002 - 15:18:50

Hallo Exel Forum!

Ich habe folgendes Problem:

In einer Tabelle1 habe ich z.B. in Spalte 1 die Bezeichnung LKF eingetragen. In Spalte 2 eine Zahl z.B. 1500.
In Tabelle2 habe ich genau für diese beiden Elemente (in Kombination), also LKF und 1500 einen Betrag hinterlegt z.B. 1000.

Ich hätte gerne in Spalte 3 von Tabelle1 1000 stehen, wenn ich in Spalte 1 LKF und in Spalte 2 1500 eingebe.

Das Ergebnis soll folgendes ergeben:
Ich lege in Tabelle2 eine Liste an, in der immer 2 Werte kombiniert werden z.B. LKF 1500. LKF 2000, RB 1500, ... hinter denen dann jeweils ein Zahlenwert steht. Wenn ich jetzt in Tabelle1 irgendeine dieser Kombinationen in die beiden ersten Spalten eintrage, soll in Spalte 3 der zugeordnete Zahlenwert erscheinen.

Ich hoffe mich nicht zu kompliziert ausgedrückt zu haben.

Gibt es hierfür ein Lösung?

Vielen Dank im Vorraus.

Gruß Michael

nach oben   nach unten

Re: Vergleich von Werten
von: Rolf, Lgh.
Geschrieben am: 15.05.2002 - 18:28:05

Hallo Michael,
eine Möglichkeit wäre die Funktion DBAUSZUG
https://www.herber.de/forum/archiv/64to68/t64575.htm
oder eine angepasste SVERWEIS
https://www.herber.de/mailing/038598h.htm.
Gruss Rolf
nach oben   nach unten

Re: Vergleich von Werten
von: MikeS
Geschrieben am: 15.05.2002 - 19:52:41

Hi Michael,

habe das Problem so gelöst:

Tabelle1

MS Excel von MikeS an Rolf, Lgh.
 ABCD
1LKF1000=A1&B1=WENN(ISTFEHLER(SVERWEIS(C1;Tabelle2!$A$1:$B$5;2;FALSCH));"";SVERWEIS(C1;Tabelle2!$A$1:$B$5;2;FALSCH))
2RB1500ergibt:LKF1000 
3ABC2000inC1 

Die Spalte C ist Deine Hilfsspalte, in der die zusammengesetzten (A1&B1) Werte stehen.
Am Ende kannst Du diese auch ausblenden.

Gib also beliebig viele Buchstaben-/Zahlenkombinationen in den Spalten A/B ein.

Kopiere die Formel aus C1 soweit nach unten, wie Du Eingaben in den Spalten A+B machen willst.
so verfährst Du auch mit der Formel aus D1.

Nun legst Du in Tabelle 2 (Kopiere einfach die Spalte C aus Tabelle1 in die Spalte A in Tabelle2 -Inhalte einfügen - Werte - und lösche
die doppelten Einträge aus der Liste raus) Deine "Datenbank" an.

In die Spalte B der Tabelle2 gibst Du nun die jeweiligen Werte ein, die in Spalte D automatisch durch
die Formel eingefügt werden.

Die SVERWEIS-Formel mußt Du nur noch anpassen.
Stehen Deine Werte in der Tabelle2 von A1:B30, dann ändere einfach $A$1:$B$5 in $A$1:$B$10 um.

Alles klar???

Ciao MikeS




nach oben   nach unten

Re: Vergleich von Werten
von: MikeS
Geschrieben am: 16.05.2002 - 07:24:04

Nachtrag:

Wenn Du die SVERWEIS-Formel abänderst kannst Du auf die Hilfsspalte C in Tabelle1 verzichten.

=WENN(ISTFEHLER(SVERWEIS(A1&B1;Tabelle2!$A$1:$B$5;2;FALSCH));"";SVERWEIS(A1&B1;Tabelle2!$A$1:$B$5;2;FALSCH))

Ciao MikeS

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Vergleich von Werten"