Microsoft Excel

Herbers Excel/VBA-Archiv

Formel ausblenden | Herbers Excel-Forum


Betrifft: Formel ausblenden von: Heinz H.
Geschrieben am: 20.01.2012 23:56:34

Hallo Leute

Ich habe in G3:G5000 untenstehende Formel.
Kann die Formel,erst eingeblendet werden,WENN in C ein Wert eingetragen wurde?
Gruß
Heinz

=WENN($C125="";"";WENN(ISTFEHLER(SVERWEIS($C125;Artikeln!$A$2:$F$49999;6;FALSCH));"";SVERWEIS($C125; Artikeln!$A$2:$F$49999;6;FALSCH))) 

  

Betrifft: was verstehst du unter "ausblenden"? o.T. von: Josef Ehrensberger
Geschrieben am: 21.01.2012 00:02:57

« Gruß Sepp »



  

Betrifft: AW: was verstehst du unter "ausblenden"? o.T. von: Heinz H.
Geschrieben am: 21.01.2012 00:07:15

Hallo Josef

was verstehst du unter "ausblenden"? 

Das war eine blöde Fragestellung von mir!! - Sorry

Könnte man die Formel eventuell mittels VBA einblenden,wenn in C ein Eintrag gemacht wurde?

Danke
Heinz


  

Betrifft: AW: was verstehst du unter "ausblenden"? o.T. von: Josef Ehrensberger
Geschrieben am: 21.01.2012 00:20:04


Hallo Heinz,

ins Modul der Tabelle.

' **********************************************************************
' Modul: Tabelle8 Typ: Element der Mappe(Sheet, Workbook, ...)
' **********************************************************************

Option Explicit

Private Sub Worksheet_Change(ByVal Target As Range)
  Dim rng As Range
  
  On Error GoTo ErrExit
  If Not Intersect(Target, Range("C3:C50000")) Is Nothing Then
    Application.EnableEvents = False
    For Each rng In Intersect(Target, Range("C3:C50000")).Cells
      If rng <> "" Then
        rng.Offset(0, 4).FormulaR1C1 = "=IF(RC3="""",""""," & _
          "IF(ISERROR(VLOOKUP(RC3,Artikeln!R2C1:R49999C6,6,FALSE)),""""," & _
          "VLOOKUP(RC3, Artikeln!R2C1:R49999C6,6,FALSE)))"
      Else
        rng.Offset(0, 4) = ""
      End If
    Next
  End If
  ErrExit:
  Application.EnableEvents = True
End Sub






« Gruß Sepp »



  

Betrifft: Josef du bist S P I T Z E von: Heinz H.
Geschrieben am: 21.01.2012 01:58:17

Hallo Josef

Echt S U P E R !!!
Recht herzlichen Dank

Gruß
Heinz


Beiträge aus den Excel-Beispielen zum Thema "Formel ausblenden"