Microsoft Excel

Herbers Excel/VBA-Archiv

Gedankenfehler?! | Herbers Excel-Forum


Betrifft: Gedankenfehler?! von: Astrid
Geschrieben am: 23.01.2012 21:13:07

Hallo Ihr Lieben,
ich habe kleine Datei angehängt, in der ich gern Zahlen
vergleichen möchte..
Hat jemand eine Idee? wo mein Gedankenfehler liegt?

https://www.herber.de/bbs/user/78571.xlsx

Ich bedanke mich schon ganz herzlich für die viele Mühe.
Gruss Astrid

  

Betrifft: AW: Gedankenfehler?! von: Josef Ehrensberger
Geschrieben am: 23.01.2012 21:17:31


Hallo Astrid,

der Fehler ist, das du Text (Zeile 3) mit Zahlen (Zeile 5) vergleichst.

Tabelle1

 ABCDEFGHIJK
1Zahl: 578141          
2           
3 578141=trennung wert in zelle a1  
4           
5 248131=meine zahlen  
6           
7 001101=vergleich zeile 3 u. zeile 5  
8        rote zahl = fehler!  
9           
10        hinweis: jede einzelne zahl braucht  
11        seine eigene zelle!  
12           

Formeln der Tabelle
ZelleFormel
B3=TEIL($A$1;7;1)*1
B7=WENN(B3=B5;1;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Gedankenfehler?! von: Gerhard
Geschrieben am: 23.01.2012 21:36:06

Hallo Astrid,

in den Zellen der zerlegten Zahl befinden sich nicht die angezeigten Werte sondern Formeln, also sind sie nicht zu vergleichen und nie identisch. Die Werte müssten erst ihrer Formel beraubt werden. Kopiern und Werte eintragen, dann geht's!
Grüße Gerhard


  

Betrifft: na das ist aber vollkommener Quatsch! o.T. von: Josef Ehrensberger
Geschrieben am: 23.01.2012 21:41:13

« Gruß Sepp »



  

Betrifft: AW: na das ist aber vollkommener Quatsch! o.T. von: Astrid
Geschrieben am: 23.01.2012 21:57:41

Trotzdem Dankel, Gerhard, für Deine Mühe.
doch die Lösung von Sepp hat schon geholfen und war genau das,
was ich suchte.
Es geht also doch...

LG Astrid