Microsoft Excel

Herbers Excel/VBA-Archiv

FormulaLocal | Herbers Excel-Forum


Betrifft: FormulaLocal von: WalterK
Geschrieben am: 01.02.2012 15:41:04

Hallo,

in FormulaLocal wollte ich schreiben: =SUMME(" & LeSpa2 & "3:" & LeSpa3 & "3), das geht aber nicht!

zur INFO: LeSpa2 = Spalte 4 und LeSpa3 = Spalte 16

Es soll die Summe(D3:P3) gebildet werden.

Mit meinem o.a. Versuch aber als Formel "=Summe(43:163)" in der Zelle.

Wie muss ich diese variable Formel richtig schreiben?

Besten Dank und Servus, Walter

  

Betrifft: AW: FormulaLocal von: Josef Ehrensberger
Geschrieben am: 01.02.2012 15:55:11


Hallo Walter,

Range("A1").FormulaLocal = "=SUMME(" & Range(.Cells(3, LeSpa2), Cells(3, LeSpa3)).Address(0, 0) & ")"





« Gruß Sepp »



  

Betrifft: AW: FormulaR1C1Local von: Rudi Maintaire
Geschrieben am: 01.02.2012 15:55:18

Hallo,
dann müssten LeSpa2 und leSpa3 Buchstaben sein.
.FormulaR1C1Local = "=Summe(Z3S" & leSpa2 & ":Z3S" & leSpa3 & ")"

Gruß
Rudi


  

Betrifft: Danke Euch bestens, Servus Walter von: WalterK
Geschrieben am: 01.02.2012 16:13:11