Microsoft Excel

Herbers Excel/VBA-Archiv

Dienstplan | Herbers Excel-Forum


Betrifft: Dienstplan von: Kentsch
Geschrieben am: 01.02.2012 19:11:33

Hallo zusammen

Ich erstelle derzeit einen Dienstplan der aus einer Legende heraus Dienste vergleicht und die Anzahl der Stunden in einer Zelle unterhalb des Dienst-Kürzels wie "F1" zurückgibt. - Muss ein zweiter Dienst vergeben werden, zwecks Tausch ect., so wird dieser darunter eingetragen. Mit der Formel nimmt er den neuen Dienst und trägt hierfür die Zeit ein.
=SVERWEIS(WENN(H8<>"";H8;H7);Legende!$A:$F;5;FALSCH)

Mein Problem ist es, dass ein Eintrag "K" für Krank unbrücksichtigt bleiben soll und hierfür wieder die erste Zelle berücksichtigt weden soll, da für einen Krankenstand nur der erst genommene Dienst zählt.

Es wäre toll, wenn mir dabei jemand helfen kann.
schon jetzt Danke

  

Betrifft: AW: Dienstplan von: Dirk
Geschrieben am: 01.02.2012 20:31:28

Hallo Kentsch

den befehl Legende kenn ich leider nicht.

du suchst aber so wie ich das verstehe eine einfache wenn funktion

=wenn(h8="k";h7;"weiterer befehl")

wenn du in deiner Formel an der Stelle angekommen bist, wo es kritisch wird (k oder doch was anderes)
sollte das eigenlich passen, wenn du dass mit ner wenn abfrage lenkst

Gruß
Dirk


  

Betrifft: AW: Dienstplan von: Kentsch
Geschrieben am: 02.02.2012 18:49:19

Hallo Dirk

Zunächst einmal danke, dass Du dich meines Problems annimmst.

Ich habe die Formel auprobiert, sie hat leider nicht den Erfolg gebracht, den ich suche.
Vielleicht nochmal zur Formel - Legende icst das Tabellenblatt in dem alle Dienste und Stunden hinterlegt sind. Im Dienstplan greift die Formel darauf zurück. ist in der obersten Zelle ein Eintrag nimmt er diesen und rechnet mit der Stundenzahl die in der Legende hinterlegt ist. Steht in der zweiten Tabelle ein anderer Dienst (wegen Tauschen des Dienstes) greift die Formel auf diesen Wert.
Meine Frage ging dahin, dass die berechnung mit diesen Diensten auch beibehalten wird, eben nur beim Eintrag "K" nicht.
Ich habe zwar versucht deine Formel umzustricken, bin aber noch nicht weiter gekommen.

https://www.herber.de/bbs/user/78704.xls

Vielleicht schaust Du mal in die tabelle rein.

Danke


  

Betrifft: AW: Dienstplan von: Dirk
Geschrieben am: 02.02.2012 19:19:59

wenn ich dich jetz richtig verstanden habe möchtetest du den "A" zugehöhrigen wert verwenden, wenn "B" =K ist.

uff hoffendlich verstehst du was ich meine :-D

wie währ es denn dann hiermit

=SVERWEIS(WENN(D2="";D1;WENN(D2="K";D1;D2));G:H;2)
Gruß
Dirk


  

Betrifft: AW: Dienstplan von: Kentsch
Geschrieben am: 02.02.2012 20:21:35

Hallo Dirk

Vielen Dank
Genau die Formel ist es.

Du hast mir damit echt sehr viel weiter geholfen.

Aber so wie ich das Projekt kenne, werden sicher noch ein paar Problemchen auftauchen.

Gruß


  

Betrifft: AW: Dienstplan von: Kentsch
Geschrieben am: 02.02.2012 20:13:01

Hallo Dirk

Vielen Dank
Genau die Formel ist es.

Du hast mir damit echt sehr viel weiter geholfen.

Aber so wie ich das Projekt kenne, werden sicher noch ein paar Problemchen auftauchen.

Gruß