Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen mehrerer Kriterien



Excel-Version: 8.0 (Office 97)

Betrifft: Zählen mehrerer Kriterien
von: Gerald
Geschrieben am: 07.06.2002 - 10:17:59

Hallo, folgendes Problem:
In Spalte A stehen verschiedene Namen, die auch mehrmals vorkommen können (z.B. der name KLAUS)
In Spalte B stehen verschiedene Werte zu den einzelnen namen (zahlen zwischen 1 und 2000).
Excel soll nun in einem neuen Arbeitsblatt ausdrücken, wie oft z.B. der Name Klaus in Spalte A mit einem Wert in Spalte B >42 vorhanden ist.
  

Re: Zählen mehrerer Kriterien
von: Hans W. Herber
Geschrieben am: 07.06.2002 - 10:24:17

Hallo Gerald,

diese Aufgaben löst man mit Matrixformeln:
=SUMME((A1:A100="Klaus")*(B1:B100<42)*1)

Matrixformeln sind in der Bearbeitungsleiste kenntlich an den sie umgebenden geschweiften Klammern und werden mit der Tastenkombination STRG+UMSCHALT+EINGABE ohne diese Klammern eingegeben.

Das Thema Matrixformeln wurde in meinem Excel-Tutorial ausführlich behandelt.

hans

  

Re: Zählen mehrerer Kriterien
von: Gerald
Geschrieben am: 07.06.2002 - 11:25:00

danke für den Tipp

 

Beiträge aus den Excel-Beispielen zum Thema "Zählen mehrerer Kriterien"