Microsoft Excel

Herbers Excel/VBA-Archiv

Auto Ausfüllen nach Vorgabe | Herbers Excel-Forum


Betrifft: Auto Ausfüllen nach Vorgabe von: Thomas Jestl
Geschrieben am: 27.07.2012 10:40:13

Hallo Forum,
ich habe eine Frage.
Wie kann ich zum Beispiel eine Spalte mit vorher definierten Kriterien ausfüllen lassen?
Ich meine nicht die klassische Ausfüllmethode mit Maus ziehen, sondern das Programm sollte dies selbstständig machen.

Z.B.
Ich habe eine Toleranzuntergrenze von z.B 5, und eine Obergrenze von 15.
Ich will jetzt dass das Programm nach einer vorgegebenen Schrittzahl von z.B. 0,5 autmatisch eine Spalte erzeugt mit den Werten 5, 5.5, 6, 6.5,..usw bis zur oberen Grenze

Wenn ich die Die Vorgaben stehen in einem Zellbezug, und wenn ich die Werte ändere sollen sich Spaltenwerte automatisch anpassen.
Geht das?

Ich hoffe ich habe mein Problem verständlich ausgedrückt, und bedanke mich vorab für eure Info.

Lg
Thomas

  

Betrifft: AW: Auto Ausfüllen nach Vorgabe von: Eugen Wenderhold
Geschrieben am: 27.07.2012 11:50:24

Hallo Thomas,

schau Dir das mal an

https://www.herber.de/bbs/user/81176.xlsm

mfg

wd


  

Betrifft: AW: Auto Ausfüllen nach Vorgabe von: Thomas Jestl
Geschrieben am: 27.07.2012 14:33:39

Hallo Eugen !
Danke für die schnelle Antwort, wies aussieht ist das mit VBA umgesetzt worden, oder?
Grund mehr mich mit VBA auseinanderzusetzen!

GLG und schönes Wochenende!

Thomas


  

Betrifft: AW: Auto Ausfüllen nach Vorgabe von: Uwe (:o)
Geschrieben am: 27.07.2012 12:01:23

Hallo Thomas,
meinst Du das so:
Tabelle1

 ABCDEFGHIJKLMNOPQRSTUVWX
1Schrittweite:55,566,577,588,599,51010,51111,51212,51313,51414,515  
20,5                       
3Untergrenze:                       
45                       
5Obergrenze:                        
615                       

Formeln der Tabelle
ZelleFormel
B1=A4
C1=WENN(ISTZAHL(B1); WENN(B1+$A$2<=$A$6;B1+$A$2;""); "")
D1=WENN(ISTZAHL(C1); WENN(C1+$A$2<=$A$6;C1+$A$2;""); "")
E1=WENN(ISTZAHL(D1); WENN(D1+$A$2<=$A$6;D1+$A$2;""); "")
F1=WENN(ISTZAHL(E1); WENN(E1+$A$2<=$A$6;E1+$A$2;""); "")
G1=WENN(ISTZAHL(F1); WENN(F1+$A$2<=$A$6;F1+$A$2;""); "")
H1=WENN(ISTZAHL(G1); WENN(G1+$A$2<=$A$6;G1+$A$2;""); "")
I1=WENN(ISTZAHL(H1); WENN(H1+$A$2<=$A$6;H1+$A$2;""); "")
J1=WENN(ISTZAHL(I1); WENN(I1+$A$2<=$A$6;I1+$A$2;""); "")
K1=WENN(ISTZAHL(J1); WENN(J1+$A$2<=$A$6;J1+$A$2;""); "")
L1=WENN(ISTZAHL(K1); WENN(K1+$A$2<=$A$6;K1+$A$2;""); "")
M1=WENN(ISTZAHL(L1); WENN(L1+$A$2<=$A$6;L1+$A$2;""); "")
N1=WENN(ISTZAHL(M1); WENN(M1+$A$2<=$A$6;M1+$A$2;""); "")
O1=WENN(ISTZAHL(N1); WENN(N1+$A$2<=$A$6;N1+$A$2;""); "")
P1=WENN(ISTZAHL(O1); WENN(O1+$A$2<=$A$6;O1+$A$2;""); "")
Q1=WENN(ISTZAHL(P1); WENN(P1+$A$2<=$A$6;P1+$A$2;""); "")
R1=WENN(ISTZAHL(Q1); WENN(Q1+$A$2<=$A$6;Q1+$A$2;""); "")
S1=WENN(ISTZAHL(R1); WENN(R1+$A$2<=$A$6;R1+$A$2;""); "")
T1=WENN(ISTZAHL(S1); WENN(S1+$A$2<=$A$6;S1+$A$2;""); "")
U1=WENN(ISTZAHL(T1); WENN(T1+$A$2<=$A$6;T1+$A$2;""); "")
V1=WENN(ISTZAHL(U1); WENN(U1+$A$2<=$A$6;U1+$A$2;""); "")
W1=WENN(ISTZAHL(V1); WENN(V1+$A$2<=$A$6;V1+$A$2;""); "")
X1=WENN(ISTZAHL(W1); WENN(W1+$A$2<=$A$6;W1+$A$2;""); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß
Uwe
(:o)


  

Betrifft: AW: Auto Ausfüllen nach Vorgabe von: Thomas Jestl
Geschrieben am: 27.07.2012 14:37:33

Servus Uwe ,
danke für deine schnelle Antwort, ich werde mich mit deinem Vorschlag am WE gleich mal spielen !
Für weitere Fragen hoffe ich dass ich euch weiter belästigen darf :-)

GLG und schönes Wochenende!

Thomas


Beiträge aus den Excel-Beispielen zum Thema "Auto Ausfüllen nach Vorgabe"