goto



Excel-Version: 9.0 (Office 2000)
  • goto von Joachim S vom 18.06.2002 - 16:54:41
    • Re: goto von Hajo vom 18.06.2002 - 17:00:35
      • Re: goto von Joachim S vom 18.06.2002 - 17:08:37
        • Re: goto von Hajo vom 18.06.2002 - 17:15:22
          • Re: goto von Joachim S vom 18.06.2002 - 17:24:28
nach unten

Betrifft: goto
von: Joachim S
Geschrieben am: 18.06.2002 - 16:54:41

Ich habe in meinem Makro folgende Zeilen

If Cells(3, 33) = "falsch" Then GoTo start
    If Cells(3, 35) = "falsch" Then GoTo start
    If Cells(3, 37) = "falsch" Then GoTo start

Aber sie werden beim Programmablauf (ohne Fehlermeldung) nicht berücksichtigt
was ist falsch??

nach oben   nach unten

Re: goto
von: Hajo
Geschrieben am: 18.06.2002 - 17:00:35

Hallo Joachim

Du überprüftst ob in den Zellen das Wort falsch (kleingeschrieben) drin steht. Diese wort bekommts Du aber nur rein wenn Du vor dem Wort ein Hochkomma machst ansonsten sind alle Buchstaben groß falsch ist verschieden von FALSCH. Oder was willst Du prüfen.

Gruß Hajo


nach oben   nach unten

Re: goto
von: Joachim S
Geschrieben am: 18.06.2002 - 17:08:37

in den Zellen steht folgende Formel
=WENN(AG2>AUFRUNDEN(ZÄHLENWENN($B$1:$B$23;AG1)/$E$1;0);"falsch";"ok")
bei falsch soll das Makro von vorne bzw. Start wieder beginnen
nach oben   nach unten

Re: goto
von: Hajo
Geschrieben am: 18.06.2002 - 17:15:22

Hallo Joachim

"bei falsch soll das Makro von vorne bzw. Start wieder beginnen"

sind zwei unterschiedliche sachen Start ist eine Sprungmarke die im code steht mit Start:

bei mir läuft es Fehlerfrei

Gruß Hajo

nach oben   nach unten

Re: goto
von: Joachim S
Geschrieben am: 18.06.2002 - 17:24:28

Ich habe jetzt start1 start2 und start3
genommen jetzt gehts

Vielen Dank


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Internet und Excel"