Urlaubsdaten



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Urlaubsdaten
von: Thorsten
Geschrieben am: 27.06.2002 - 10:30:53

Hallo liebe Excel-Gemeinde,
ich erstellle z.Z gerade eine Urlaubsdatei.
Wenn jemand 40 Jahre alt wird, bekommt er mit Beginn des Geburtstagsjahres 29 Tage Urlaub.
(Bsp: M1 wird am 28.12.2002 40 und bekommt schon ab 1.01.2002 29 Tage Urlaub)
Folgende Formel habe ich schon (für Mitarbeiter die unter bzw. über 30 Jahre sind): WENN(B9>30;27;WENN(B9<=30;25;))
Wie kann ich das nun für die über 40-jährigen noch in der Formel unterkriegen?
nach oben   nach unten

Re: Urlaubsdaten
von: Hans W Hofmann
Geschrieben am: 27.06.2002 - 10:35:20

Hallo Thorsten,

Du mußt Deine Bedingungen nur der Reihe nach ordnen.
WENN(Typ<=30;1;WENN(Typ<40;2;3))

Gruß HW


nach oben   nach unten

Re: Urlaubsdaten
von: Frederik
Geschrieben am: 27.06.2002 - 10:35:54

Hallo!

Dann musst du einfach noch ein wenn anhängen:

..27;WENN(B9<=30;25;wenn(b9>40;30)

Frederik

nach oben   nach unten

Re: Urlaubsdaten
von: Thorsten
Geschrieben am: 27.06.2002 - 10:57:24

Hallo Hans
vielen Dank für den Tip, aber ich habe mich glaube ich falsch ausgedrückt.
Nochmals ein Bsp.: M1 (Geburtsdatum:28.8.1962) wird am 28.08.02 vierzig und ist lt. meiner Altersberechnung
(WENN(B10=B100;"";JAHR(HEUTE()+1-B10)-1900 ja noch 39 Jahre alt.
Er bekommt aber ab 1.01.02 schon 29 Tage Urlaub.
In 2001 war er zwar auch schon 39, bekommt aber noch 27 Tage.
Irgendwie muß es sich auf den 1.01.02 beziehen. Meine Idee war folgende, die geht aber nicht.
WENN(B9>30;27;WENN(B9<=30;25;WENN(B9=Heute="1.01.02";29;)

nach oben   nach unten

Re: Urlaubsdaten
von: Thorsten
Geschrieben am: 27.06.2002 - 10:59:49

Hallo!

Vielen Dank für Dein Tip.
mfg
Thorsten


nach oben   nach unten

Re: Urlaubsdaten
von: Heinz
Geschrieben am: 27.06.2002 - 13:43:15

Hallo Thorsten,

ich habe so ein Problem für die Altersvorsorge einer Firma mal durchgeführt. Ich schicke dir direkt meine Tabelle, schau sie dir mal an.

Gruß Heinz


nach oben   nach unten

Re: Urlaubsdaten
von: Volker
Geschrieben am: 27.06.2002 - 13:45:44

Hallo Thorsten,

interessant ist doch nur das Geburtsjahr des Mitarbeiters. Versuche mal folgendes:

In Zelle A1 (Zelle A1 ist als Text formatiert) steht das Geburtsdatum und in B1 dann:

=WENN(JAHR(HEUTE())-JAHR(DATWERT(A1))>=40;29;WENN(JAHR(HEUTE())-JAHR(DATWERT(A1))>=30;27;WENN(JAHR(HEUTE())-JAHR(DATWERT(A1))<30;25;)))

Gruss Volker

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Übergeordneter Ordner"