nur addieren wenn ein anderes Feld ausgefüllt ist



Excel-Version: 10.0 (Office XP)
nach unten

Betrifft: nur addieren wenn ein anderes Feld ausgefüllt ist
von: Wonne
Geschrieben am: 28.06.2002 - 17:26:50

Hallo mal wieder

Ich habe das Problem das ich eine Zeile aus multiplikatoren habe die nur addiert werden sollen wenn in einem bestimmten Feld eine Zahl steht.

Kann mir jemand sagen wie das geht???

Danke Wonne


nach oben   nach unten

Re: nur addieren wenn ein anderes Feld ausgefüllt ist
von: Bonte
Geschrieben am: 28.06.2002 - 18:45:47

Hallo Wonne,

mal ein Ansatz. ist nicht besonders elegant, aber funktioniert für diese wenigen Werte.


Private Sub Worksheet_SelectionChange(ByVal Target As Excel.Range)
If Range("A1").Value <> "" Then
    Range("D5").Value = Range("A5").Value + Range("B5").Value + Range("C5").Value
Else
    Range("D5").ClearContents
End If
End Sub
     Code eingefügt mit Syntaxhighlighter 1.14

Gruß
Bonte

nach oben   nach unten

Re: nur addieren wenn ein anderes Feld ausgefüllt ist
von: PeterW
Geschrieben am: 28.06.2002 - 18:47:50

Hallo Wonne,

kannst Du das Problem etwas genauer beschreiben? Stehen die Werte in mehreren Zellen und das Ergebnis soll in eine andere Zelle wenn in einem bestimmten Feld etwas eingegeben ist/wird? In welche Richtung soll die Abhängigkeit gehen, Eingabe in das bestimmte Feld und dann Berechnung oder nach Eingabe der Multiplikatoren die Berechnung sofern in der bestimmten Zelle etwas steht? Bist Du sicher, dass Multiplikatoren summiert werden sollen?

Gruß
Peter


nach oben   nach unten

Re: nur addieren wenn ein anderes Feld ausgefüllt ist
von: Smine
Geschrieben am: 28.06.2002 - 19:58:18

Hallo Wonne,

normal ist das keine große Schwierigkeit. Aber da Du möglicherweise eine Lösung via Makro willst, die ich dir nicht geben kann, diese einfache Formel hier unter Vorbehalt:

=WENN([bestimmtezellemitderzahl]="";"";[summediedubildenwillst])

Beispiel:

=WENN(D20="";"";SUMME(A1:B10))

So arbeitet die Formel:

Wenn die Zelle D20 leer ist(D20=""), dann schreibe nichts (;""), ansonsten schreibe die Summe des Bereiches A1 bis B10 (;SUMME(A1:B10))

Hoffe, es hilft Dir weiter

Gruß Smine

nach oben   nach unten

Re: nur addieren wenn ein anderes Feld ausgefüllt ist
von: Wonne
Geschrieben am: 29.06.2002 - 01:09:02

Ja die multiplikatoren sollen addiert werden wennn in einem anderen Feld (mit denen die Multiplikatoren multipliziert werden wenn etwas darin steht) und wenn da etwas drin steht soll der Multiplikator in ein anders Feld addiert werden

Wonne


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "nur addieren wenn ein anderes Feld ausgefüllt ist"