Mehr als 7 Bedingungen in WENN FKT



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Mehr als 7 Bedingungen in WENN FKT
von: Jens
Geschrieben am: 01.07.2002 - 14:20:18

Hallo Zusammen

Ich möchte eine wenn Funktion für Rabattstaffelungen stricken. D.h. einen Gewissen Rabatt gewähren wenn der Umsatz so hoch ist. Dies macht man sehr einfach mit einer Verschachtelten wenn FKT. Excel hat eine Begrenzung von 7 Bedingungen in einer Wenn Funktion. Ich habe aber 10 Rabattstaffeln.Kann man dies auch mit einem Trick umgehen, bzw. erweitern?????

Danke für eure Hilfe

Gruß Jens


nach oben   nach unten

Re: Mehr als 7 Bedingungen in WENN FKT
von: Hajo_Zi
Geschrieben am: 01.07.2002 - 14:24:35

Hallo Jens

bei mehr als 7 Wenn sollte man schon eine Verweis Funktion nehmen z.B. Sverweis.

346. Mehr als 8 Wenn
=WENN(A1=1;1;WENN(A1=2;2;WENN(A1=3;3;WENN(A1=4;4;WENN(A1=5;5;WENN(A1=6;6;WENN(A1=7;7;)))))))+WENN(A1=8;8;WENN(A1=9;9;WENN(A1=10;10;WENN(A1=11;11;WENN(A1=12;12;)))))
von WF


Gruß Hajo


nach oben   nach unten

Re: Mehr als 7 Bedingungen in WENN FKT
von: Jens
Geschrieben am: 01.07.2002 - 14:27:39

Habe ich auch schon versucht. Das Problem:
BSP: Man bekommt 25 Rabatt wenn der Umsatz zw. 5.000€ und 10.000€ liegt. D.H. er kann aus dieser Tabelle keinen eindeutigen Wert auslesen. Von daher ist meiner Meinung ein SVERWEIS nicht möglich.Oder irre ich mich

Gruß JEns

nach oben   nach unten

Re: Mehr als 7 Bedingungen in WENN FKT
von: M@rkus
Geschrieben am: 01.07.2002 - 14:29:08

Nimm dir eine Weitere Zelle dazu und verweise in deiner Funktion darauf.
=WENN(A1=2;10;WENN(A1=3;11;WENN(A1=4;12;B1)) usw.

Gruss Markus


nach oben   nach unten

Re: Mehr als 7 Bedingungen in WENN FKT
von: Berai
Geschrieben am: 01.07.2002 - 14:29:45


Hallo Jens,

setze nach jeder 7-ten Verschachtelung ein "+" und Du kannst solange Verschachteln, bis Du den Überblick verlierst.
Hier ein Beispiel mit 21 Verschachtelungen (wenn ich richtig gezählt habe).

=WENN(A1=1;1;WENN(A1=2;2;WENN(A1=3;3;WENN(A1=4;4;WENN(A1=5;5;WENN(A1=6;6;WENN(A1=7;7;0)))))))+WENN(A1=8;8;WENN(A1=9;9;WENN(A1=10;10;WENN(A1=11;11;WENN(A1=12;12;WENN(A1=13;13;WENN(A1=14;14;0)))))))+WENN(A1=15;15;WENN(A1=16;16;WENN(A1=17;17;WENN(A1=18;18;WENN(A1=19;19;WENN(A1=20;20;WENN(A1=21;21;0)))))))

Gruß
Rainer


nach oben   nach unten

Re: Mehr als 7 Bedingungen in WENN FKT
von: Kl@us-M.
Geschrieben am: 01.07.2002 - 14:30:21

Hallo Jens,
die Frage ist bestimmt schon 1.000 mal gestellt worden, eine Suche im Archiv oder der Recherche hätte Dich auch auf die Lösung gebracht:
wenn(a1=1;1;wenn(a2=2;2 ... wenn(a8=8;8))) + wenn(a9=9;9;wenn(a10=10;10...
Gruss
Klaus-Martin
nach oben   nach unten

Re: Mehr als 7 Bedingungen in WENN FKT
von: Hajo_Zi
Geschrieben am: 01.07.2002 - 14:35:55

Hallo Jens
bis 5000 =0
bis 10000 =1
bis 15000 =2
usw.
In A23 0;A24 5000; A25 10000; A26 15000 usw.
in B23 0; B24 1 B25 2; B26 3 usw.

Der Wert steht in D23 und E23 folgende Formel =SVERWEIS(D23;A23:B27;2;1)

Gruß Hajo

nach oben   nach unten

Re: Mehr als 7 Bedingungen in WENN FKT
von: JEns
Geschrieben am: 01.07.2002 - 14:37:01

DANKE FÜR EURE HILFE.

GRUß JENS


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Mehr als 7 Bedingungen in WENN FKT"