Microsoft Excel

Herbers Excel/VBA-Archiv

Laufzeitfehler bei Activate

Betrifft: Laufzeitfehler bei Activate von: André
Geschrieben am: 29.08.2014 14:47:16

Hallo liebes Forum,

ich habe ein seltsames Problem.

Um eine Exceldatei immer mit dem ersten Tabellenblatt zu öffnen, habe ich unter "DieseArbeitsmappe" folgendes eingefügt.

Private Sub Workbook_Open()
   ActiveWorkbook.Worksheets(1).Activate
End Sub
Funktioniert auch super.

Auf meinem Rechner.

Wenn ein Kollege mit Office 2010 dieselbe Datei öffnen will, bekommt er einen Laufzeitfehler 1004.

Weiß jemand, woran das liegen kann?

Danke schön schon mal
André

  

Betrifft: AW: Laufzeitfehler bei Activate von: Hajo_Zi
Geschrieben am: 29.08.2014 15:03:43

Hallo André,

nur wenige sehen Deine Dateien und können das testen. Die erste Tabelle ist schon eingeblendet?

GrußformelHomepage


  

Betrifft: AW: Laufzeitfehler bei Activate von: André
Geschrieben am: 29.08.2014 15:15:22

Hallo Hajo,

die Datei kann ich nicht hochladen. Da sind zu viele sensible Daten enthalten.

Aber bei einer Testdatei haben wir dasselbe Problem.

https://www.herber.de/bbs/user/92391.xlsm

Nur bekommt der Kollegen hier den Laufzeitfehler 91 Objektvariable oder With-Blockvariable nicht festgelegt.

Bei mir funktionierts.

Die erste Tabelle ist auf jeden Fall nicht ausgeblendet.


  

Betrifft: AW: Laufzeitfehler bei Activate von: UweD
Geschrieben am: 29.08.2014 15:21:38

Hallo

versuch mal so...


ThisWorkbook.Worksheets(1).Activate

Gruß UweD


  

Betrifft: AW: Laufzeitfehler bei Activate von: André
Geschrieben am: 29.08.2014 15:27:39

Hallo Uwe,

dann kommt bei dem Kollegen wieder der Laufzeitfehler 1004.

Bei mir geht's...

VG
André


  

Betrifft: offen von: UweD
Geschrieben am: 29.08.2014 15:38:03




  

Betrifft: AW: Laufzeitfehler bei Activate von: Mullit
Geschrieben am: 29.08.2014 16:24:01

Hallo,

passiert das immer beim normalen Öffnen, oder nur wenn die Datei als E-Mail Anhang oder Download geöffnet werden soll?

Gruß,


  

Betrifft: AW: Laufzeitfehler bei Activate von: André
Geschrieben am: 29.08.2014 16:37:09

Nee, das passiert immer.

Mittlerweile vermute ich, dass das Problem gar nicht an Excel liegt, sondern dass meinem Kollegen irgendwelche Rechte fehlen.

Wir haben hier im Büro 10 Rechner - alle mit verschiedenen Office Versionen.

Bei allen funktionierts.

Nur bei dem Kollegen nicht.

Habe jetzt unsere EDV Abteilung gebeten, sich den Rechner mal anzusehen und gebe Rückmeldung, wenn es was zu melden gibt.

Danke erst mal und ein schönes Wochenende
André


 

Beiträge aus den Excel-Beispielen zum Thema "Laufzeitfehler bei Activate"