Microsoft Excel

Herbers Excel/VBA-Archiv

Ausziffern / OPOS

Betrifft: Ausziffern / OPOS von: yvonne
Geschrieben am: 17.09.2014 12:00:44

Das Problem ist die Abstimmung von Geldbewegungen.

Ich habe eine Tabelle vorliegen mit mehreren Spalten, Datum, Buchungstext, Umsatz Soll und Umsatz Haben

Ziel ist eine Kontenabstmmung durchzuführen.

Bei den Abstimmungen gibt es Paare die direkt zusammenpassen und welche, die sich mehreren Einzelpositonen zusammensetzen, welche durch den Buchungstext zu ersehen sind.

Das Ergebnis sollte eine Liste aller nicht ausgeglichenen Positionen sein. Im Besten Fall wo ich Spalte ``E`` nur sortieren muss nach z.B. Null (die nicht ausgelichen sind) und weiter Manuell bearbeiten kann

Kann mir da jemand helfen?

https://www.herber.de/bbs/user/92678.xls

  

Betrifft: AW: Ausziffern / OPOS von: Daniel
Geschrieben am: 17.09.2014 12:07:12

=WENN(SUMMEWENN(B:B;LINKS(B2;8)&"*";C:C)=SUMMEWENN(B:B;LINKS(B2;8)&"*";D:D);"Ausgeglichen"; "Differenz")


  

Betrifft: AW: Ausziffern / OPOS von: yvonne
Geschrieben am: 18.09.2014 11:02:12

Deine Formel ist schon richtig gut!!

Nun fehlt nur noch die ``Überzahlung`` in der Formel.

01.09.2014 E327246F | R-2010178496 ________ 56,84
01.09.2014 E327246F | R-2010178496 _______________ 56,84
17.09.2014 E327246F | R-2010178496 | G-20 __________ 56,84


  

Betrifft: AW: Ausziffern / OPOS von: yvonne
Geschrieben am: 19.09.2014 11:05:02

kann mir keiner weiter helfen???


  

Betrifft: Noch offen! owT von: Luc:-?
Geschrieben am: 23.09.2014 09:03:57

:-?


  

Betrifft: Doch, sicher! Wie wär's denn damit, ... von: Luc:-?
Geschrieben am: 23.09.2014 18:24:15

…Yvonne:

 ABCDEF
1DatumBuchungstextUmsatz SollUmsatz HabenDifferenzenText (falls Soll vorstehend)
212.02.2014E291803F | R-5364741849,35 –49,35Differenz E291803F
312.02.2014E291803F | R-53647418 | G-20 49,350Ausgleich E291803F
419.02.2014E291835F | R-53646111 | G-20 23,00+23,00Kein Soll!
508.02.2014E291840F | R-53648826 3,95+3,95 
609.02.2014E291840F | R-5364882625,40 –21,45Differenz E291840F
715.02.2014E291874F | R-53647498 2,45+2,45 
812.02.2014E291874F | R-53647498 60,00+62,45 
901.02.2014E291874F | R-5364749862,45 0Ausgleich E291874F
1011.02.2014E291881F | R-5364740264,90 –64,90Differenz E291881F
1111.02.2014E291881F | R-53647402 | G-20 64,900Ausgleich E291881F
1201.09.2014E327246F | R-201017849656,84 –56,84Differenz E327246F
1301.09.2014E327246F | R-2010178496 56,840Ausgleich E327246F
1417.09.2014E327246F | R-2010178496 | G-20 56,84+56,84Überzahlung E327246F
15E2[:E14]:=SUMMEWENN(B$2:B2;LINKS(B2;8)&"*";D$2:D2)-SUMMEWENN(B$2:B2;LINKS(B2;8)&"*";C$2:C2)
16F2[:F14]:=WENN(WENNFEHLER(SUMME(INDEX(C1:C$2;VERGLEICH(LINKS(B2;8)&"*";B1:B$2;0)):C2);C2)=0;WENN(ZÄHLENWENN(B$2:B$14;LINKS
17                      (B2;8)&"*")>1;"";"Kein Soll!");WAHL(2+VORZEICHEN(SUMMEWENN(B$2:B2;LINKS(B2;8)&"*";D$2:D2)-SUMMEWENN(B$2:B2;LINKS(B2;8)&"*";
18                      C$2:C2));"Differenz";"Ausgleich";"Überzahlung")&" "&LINKS(B2;8))
Hierbei wdn die Texte nur angezeigt, wenn auch zuvor ein Soll angegeben wurde. Fehlt das Soll ganz, wird eine (kursive) Warnung angezeigt. Die SchriftFarben in (der ggf verzichtbaren) Spalte E wurden mit dem benutzerdefinierten Format [Blau]+0,00;[Rot]–0,00;,??; erzeugt. Dagg kamen in Spalte D (Schrift als kursiv formatiert) 3 Regeln (Zellwert ist bestimmter Text - beginnend mit …) der BedingtFormatierung zum Einsatz.
Gruß, Luc :-?


 

Beiträge aus den Excel-Beispielen zum Thema "Ausziffern / OPOS"