Microsoft Excel

Herbers Excel/VBA-Archiv

Spalte dynamisch verschieben bzw addieren

Betrifft: Spalte dynamisch verschieben bzw addieren von: Sioo
Geschrieben am: 01.10.2014 13:05:53

Hallo zusammen,

habe ein Problem mit einer Tabelle.

Beschreibung der Tabelle:
Die Tabelle wird benutzt um Lieferungen nach KW zu verfolgen und mit der Planung zu vergleichen. Beispiel: In KW38 gab es 20 Lieferungen. Die Planung war aber 30 Lieferungen.

Beschreibung des Problems:
Die Spalten der Tabelle verschieben sich. Was letzte Woche noch geplant war, ist diese Woche jetzt ein fester Wert der manuell von mir geändert wird.
Jedoch gibt es eine Reihe von Formeln die sich auch ändern müssen

Beispielsweise:
=SUMME(H11:L11)hier müsste eine Spalte hinzugefügt werden zu =SUMME(H11:M11) .
=SUMME(H14:L14)/D14 , hier müsste auch eine Spalte addiert werden zu =SUMME(H14:M14)/D14
=SUMME(N11:AL11) hier müsste dann eine Spalte (von links) abgezogen werden also =SUMME(O11:AL11)

Ziel:
Den Basiswert in einer Zelle (BSP: A1) eingeben und jeweils um die Anzahl die in der Zelle steht die Spalten addieren bzw subtrahieren: In A1 = 3, sollte dann die ersten 2 Formeln um 2 Spalten ergänzen und von der 3.zwei SPalten (Anfangswert) entfernen

Hoffe ist verständlich genug ausgedrückt.

Vielen Dank & VG

  

Betrifft: ein Fall für INDEX() ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 13:42:02

Hallo,

... z.B. A1=3 und =SUMME(H11:INDEX(11:11;SPALTE(H11)-1+A1)) =SUMME(H11:J11) etc.


Gruß Werner
.. , - ...


  

Betrifft: AW: ein Fall für INDEX() ... von: Sioo
Geschrieben am: 01.10.2014 14:28:42

Hallo, das mit dem addieren klappt super! Danke!

Habe aber noch eine Verständnisfrage:

Wieso brauch ich das -1 beim addieren und beim subtrahieren funktioniert es dann so?
=SUMME(INDEX(12:12;SPALTE(I12)+$E$2):AB12)

Hatte schon immer Probleme mit Index und versuche das diesmal ordentlich zu verstehen


  

Betrifft: das wiederum hat nichts mit INDEX() zu tun ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 14:45:37

Hallo,

... sondern damit, das z.B. zu =SPALTE(I12)= 9 ein Differenzwert von z.B. =2 (wenn dieser in E2 steht) addiert 11 ergibt, welches dem Spaltenwert von K entspricht. Du willst aber die Summe von J12:AB12 bilden. Der Spaltenwert von J12 ist aber nur 10, also ...

Verständlich?


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Spalte dynamisch verschieben bzw addieren"