Microsoft Excel

Herbers Excel/VBA-Archiv

Tabellenblatt auslesen

Betrifft: Tabellenblatt auslesen von: spenski
Geschrieben am: 03.10.2014 17:27:22

https://www.herber.de/bbs/user/92957.xlsx

Hallo liebe excel freunde
ich möchte Tabellenblatt1 bereich A2:AG1500 auslesen.

Wenn in Spalte AE etwas eingetragen ist (Es wird immer ein Datum sein) ODER wenn in Spalte AF ein "JA" steht dann sollen die Zellen der Spalte A,B,C,D,X,Z,AC,AE,AF und AG der in tabellenblatt16 (in der Bsp Datei ist es Tabellenblatt2) ab Zeile 2 untereinander weggeschrieben werden.

Es kann natürlich auch passieren das in AE ein Datum steht und in AF ein "JA". Trifft das zu soll nur 1 Eintrag erfolgen damit die zeile nicht doppelt ist.

kann mir da jemand weiterlfen???

wünsch euch ein schlnen feiertag und ein erholsames wochenende
gruss
christian

  

Betrifft: AW: Tabellenblatt auslesen von: Christian
Geschrieben am: 03.10.2014 18:15:27

Hallo Christian,

ein Ansatz per Formel:

 ABCDEFGHIJK
1Name1Name2Name3Name4Name24Name26Name29Name31Name32Name33Optionen Nullwerte anzeigen abwählen!
2797808181783030.10.2014JAKFA 
38032941520323617.10.2014NEIN  
490131188315769 JAWZV 
5852895239926313.10.2014NEIN  
687983812229612 JAKFA 
74664841219814318.10.2014JAWZV 

Formeln der Tabelle
ZelleFormel
A2{=WENN(ZEILE($A1)>SUMME(WENN((Tabelle1!$AE$2:$AE$200<>"")+(Tabelle1!$AF$2:$AF$200="JA"); 1)); "";INDEX(Tabelle1!$A$2:$AG$200;KKLEINSTE(WENN((Tabelle1!$AE$2:$AE$200<>"")+(Tabelle1!$AF$2:$AF$200="JA"); ZEILE($1:$199)); ZEILE($A1)); VERGLEICH(A$1;Tabelle1!$A$1:$AG$1;0)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

MfG Christian


  

Betrifft: AW: Tabellenblatt auslesen von: Spenski
Geschrieben am: 04.10.2014 00:56:45

Hallo Christian :D

ich danke dir für deine Antwort werde es morgen Mittag testen. Müsste dann nur noch sortiert werden aber das bekomm ich mit VBA wohl gerade noch hin.

Habe um ehrlich gesagt an eine komplett VBA Lösung gedacht. Steht aber nicht in meiner anfrage.

Werde es auf jedenfall erst einmal damit probieren damit deine Arbeit nicht umsonst war


Gruß und schönes Wochenende

Feedback folgt morgen

Christian


  

Betrifft: AW: Tabellenblatt auslesen von: spenski
Geschrieben am: 04.10.2014 01:27:56

okay passt...ich danke dir :D


 

Beiträge aus den Excel-Beispielen zum Thema "Tabellenblatt auslesen"