Microsoft Excel

Herbers Excel/VBA-Archiv

Daten umwandeln

Betrifft: Daten umwandeln von: Philipp
Geschrieben am: 09.10.2014 15:13:33

Hallo Zusammen,

Wir haben eine Kontenplanänderung vor, d.h. die Kotennummern ändern sich.
Ich habe also eine Tabelle1 mit verschrienen Kontennummern die sich ändern und eine alte Buchungsliste als Tabelle2 die ich nach den neuen Konten auswerten möchte.

Tabelle1
8000 und 8010 und 8020 wird neu 7000
Jetzt möchte ich in Tabelle2 immer wenn das Konto 8000 oder 8010 oder 8020 die 7000 in einer neuen Spalte steht oder die Nummern gleich ersetzt werden, geht das???

  

Betrifft: Vorschlag ... von: neopa C (paneo)
Geschrieben am: 09.10.2014 18:05:00

Hallo Philipp,

... in Anbetracht Deines angegebenen Excel-Levels, würde ich Dir folgendes vorschlagen.

Erstelle Dir zunächst eine Sicherheitskopie Deiner Arbeitsmappe.

Erstelle in noch unbelegten und nicht benötigten Spalten eine Hilfstabelle. In dieser schreibst Du in eine Deine bisherigen Kontennummer und daneben die neuen.

Mit Hilfe dieser kleinen Tabelle und der Funktion SVERWEIS() kannst Du nun in einer weiteren Hilfsspalte Deine bisherigen Kontonummern in Deiner/n Tabelle/n die neuen zuordnen. Anschließend kannst Du die "Ergebnisse" als Werte über die alten Kontonummern kopieren.

Mehr zu SVERWEIS() findest Du z.B. hier: http://www.online-excel.de/excel/singsel.php?f=9


Gruß Werner
.. , - ...




  

Betrifft: AW: Vorschlag ... von: Philipp
Geschrieben am: 10.10.2014 13:25:24

Danke Werner,

aber es kommt ein falsches Ergebnis.

Die Hilfstabelle "Tabelle1" (aus A1;B1;C1 soll neu D1 werden)
A1 = 8000; B1 = 8010; C1 = 8020 D1 = 7000
A2 = 7001; B2 = 7001; C2 = 7002 D2 = 3333

In der Datentabelle "Tabelle2" stehen in A1-A3838
8000
8010
8020
7000
7002
7001

In B1-B3838 gibt ich jetzt den =Sverweis(A1;Tabelle1!A:D;4) Ergebnis überall 3333





  

Betrifft: der 4. Parameter von SVERWEIS() ist wichtig, ... von: neopa C (paneo)
Geschrieben am: 11.10.2014 14:20:17

Hallo Philipp,

... darauf wird in dem von mir angegeben verlinkten Seite auch hingewiesen.
Ohne es jetzt nachgestellt zu haben, nutze mal: =SVERWEIS(A1;Tabelle1!A:D;4;0)

Gruß Werner
.. , - ...


  

Betrifft: AW: der 4. Parameter von SVERWEIS() ist wichtig, ... von: Philipp
Geschrieben am: 13.10.2014 16:18:51

Danke, ich schreib jezt alles in die Spalte A dann funktioniert es.
Gruß
Philipp


 

Beiträge aus den Excel-Beispielen zum Thema "Daten umwandeln"