Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis - Übertrag Kalender

Betrifft: Sverweis - Übertrag Kalender von: sjdelphin
Geschrieben am: 12.10.2014 16:48:25

Guten Tag,

ich hoffe auf Eure Hilfe.

Beigefügt meine Tabelle.
https://www.herber.de/bbs/user/93125.xlsx

Aus dem Jahreskalender sollen die Urlaubstage in den Monatskalender (eigentlich sind es zwei Tabellen) übertragen werden. Dabei ist der Monatskalender veränderlich (über Tabellenblatt: "Hinweise") muss der betreffende Monat eingestellt werden.

Leider habe ich Probleme mit den Formel.
Könnt ihr mir helfen?

LG Sjdelphin

  

Betrifft: AW: Sverweis - Übertrag Kalender von: {Boris}
Geschrieben am: 12.10.2014 18:05:38

Hi,

in C6 des Blattes "Monatskalender":

=SVERWEIS($A6;Jahreskalender!$B:$ZZ;VERGLEICH(Monatskalender!C$4;Jahreskalender!$B$7:$ZZ$7;);)

und sowohl runter als auch nach rechts kopieren.

VG, Boris


  

Betrifft: AW: Sverweis - Übertrag Kalender von: sjdelphin
Geschrieben am: 12.10.2014 20:23:06

Danke! Ich probiere es gleich Morgen aus !
LG Silvia


  

Betrifft: AW: Sverweis - Übertrag Kalender von: sjdelphipn
Geschrieben am: 13.10.2014 07:19:47

Danke für deine schnelle Hilfe,

funktioniert hervorragend.

LG Silvia


  

Betrifft: Hyperlink - Übertrag Kalender von: sjdelphin
Geschrieben am: 13.10.2014 14:39:46

Hallo Zusammen,

ich habe doch noch eine Frage,

wenn ich im Jahreskalender die Zelle "B8" anklicke, soll per Hyperlink automatisch der Curser bis zum aktuellen Datum springen.

Beispiel: Heute ist der 7.01.2014 - der Curser müssste zu Zelle "P7"


=WENN(ISTNV(HYPERLINK("#'Jahreskalender'!7:7"&VERGLEICH(HEUTE();7:7;0);HEUTE()));""; HYPERLINK("#'Jahreskalender'!7:7"&VERGLEICH(HEUTE();7:7;0);HEUTE()))

Beigefügte Formel markiert mir aber das gesamte Arbeitsblatt, weiß jemand die richtige Formel?

Danke für Eure Hilfe.

LG Silvia


  

Betrifft: AW: Hyperlink - Übertrag Kalender von: {Boris}
Geschrieben am: 13.10.2014 15:15:51

Hi Silvia,

=WENN(ZÄHLENWENN(7:7;HEUTE());HYPERLINK("#'Jahreskalender'!Z7S"&VERGLEICH(HEUTE();7:7;0);HEUTE()))

VG, Boris


  

Betrifft: "" vergessen von: {Boris}
Geschrieben am: 13.10.2014 15:23:26

Hi Silvia,

ich hatte die Sonst-Bedingung der WENN-Funktion versehentlich nicht belegt.
So ist es richtig:

=WENN(ZÄHLENWENN(7:7;HEUTE());HYPERLINK("#'Jahreskalender'!Z7S"&VERGLEICH(HEUTE();7:7;0);HEUTE());"")

VG, Boris


  

Betrifft: AW: "" vergessen von: sjdelphin
Geschrieben am: 13.10.2014 15:34:16

Hi Boris,

bist ein Schatz - funktioniert super!

Tausend Dank!

LG Silvia


 

Beiträge aus den Excel-Beispielen zum Thema "Sverweis - Übertrag Kalender"