Microsoft Excel

Herbers Excel/VBA-Archiv

Text ein/ausblenden

Betrifft: Text ein/ausblenden von: Andy
Geschrieben am: 21.10.2014 17:56:46

Hallo
bestimmt mega einfach aber komm nicht weiter
Spalte E Stückzahl
Spalte B soll leer sein wenn E auch leer ist
Wenn in Spalte E dann eine Stückzahl steht, soll der Text
den ich auf M in den nicht druckbaren Bereich stehen hab
eingesetzt werden
=WENN(ISTZAHL(E22);M22)
einfügen geht soweit, nur wenn E leer ist kommt die Meldung
FALSCH in der Spalte B

Danke erstmal

  

Betrifft: AW: sonst fehlt von: hary
Geschrieben am: 21.10.2014 18:01:46

Moin
Versuchs mal mit dem Sonstteil.
Wenn(Pruefung;dann;sonst)
=WENN(ISTZAHL(E22);M22;"")
gruss hary


  

Betrifft: AW: sonst fehlt von: Andy
Geschrieben am: 21.10.2014 18:05:40

Hi Hary
das blick ich jetzt hier im Süden grad nicht


  

Betrifft: AW: sonst fehlt von: hary
Geschrieben am: 21.10.2014 18:18:32

Moin
????
Eine Wennformel besteht aus Pruefung(ISTZAHL(E22)), wenn wahr dann M22, sonst ""
Trag doch mal die Formel ein.

=WENN(ISTZAHL(E22);M22;"")

Aus der Hilfe:
WENN(Prüfung;Dann_Wert;Sonst_Wert)

gruss hary


  

Betrifft: AW: sonst fehlt von: {Boris}
Geschrieben am: 21.10.2014 18:23:58

Hi Andy,

so schwer ist das doch gar nicht.
Die Formel von Hary erüllt genau Deine Anfrage.

Die WENN-Funktion hat nunmal 3 Parameter:

=WENN(Prüfung;[Dann_Wert];[Sonst_Wert])

Einer der beiden Parameter Dann_Wert / Sonst_Wert MUSS angegeben werden, da die Funktion sonst ihren Dienst verweigert. Der andere ist aber optional - zu erkennen an den [eckigen Klammern] bei den Parametern. Und wenn man ihn weglässt, dann gibt es eben ein FALSCH, wenn dieser Parameter zum Tragen kommt - in Deinem Fall eben, wenn die Prüfung ISTZAHL(E22) eben NICHT zutrifft.
Und Hary hat nun den Sonst_Wert mit einem Leerstring "" belegt, damit eben kein FALSCH in der Zelle steht sondern eben (optisch) nichts.

VG, Boris


  

Betrifft: AW: sonst fehlt von: Andy
Geschrieben am: 21.10.2014 18:33:34

Hi Boris

supi die schnellen Antworten
steh trotzdem grad auf der Leitung weil in einem anderen Bereich funktioniert es

=WENN(ISTZAHL(E23);F23*E23;"")

F23und E23 wird in H berechnet und ist leer wenn E23 auch leer ist

bin glaub echt zu doof

Gruß aus RV


  

Betrifft: AW: sonst fehlt von: hary
Geschrieben am: 21.10.2014 18:39:42

Moin
In dieser Formel hast du auch den 3.Parameter drin: ;""
=WENN(ISTZAHL(E23);F23*E23;"")~f~
hier nicht.
~f~=WENN(ISTZAHL(E22);M22)
gruss hary


  

Betrifft: Alternativ würde auch Folgendes fktionieren, ... von: Luc:-?
Geschrieben am: 21.10.2014 19:09:41

…Andy:
=WENNFEHLER(F23*E23^2/E23;T(E23))
Diese Formel rechnet ebenso wie die andere auch mit TextZahlen, erzeugt aber einen Fehler, falls E23 leer oder =0 ist, wodurch dann das 2.Argument wirksam wird, was aus dem Inhalt von E23 einen Text macht. Der würde bei einer leeren E-Zelle dann dem sog LeerString "" entsprechen. Würde in E aber ein (alfabetischer) Text stehen, würde nur der angezeigt, was mitunter nützlich sein könnte. Ist dagegen die F-Zelle leer, würde kein Fehler entstehen und es würde 0 angezeigt, wenn in E eine Zahl steht. Enthält die F-Zelle aber einen Text (keine TextZahl!), ergibt sich wieder ein Fehler und E wird als Text interpretiert, was bei einer echten Zahl ebenfalls einen LeerString ergäbe, während ein Text oder eine TextZahl angezeigt wdn würde.
Auf diese Weise kannst man du dir auch noch raffiniertere FehlerKontrollen und Alternativ­Ergebnisse überlegen, falls dich das nicht gänzlich überfordern sollte… ;-]
Gruß, Luc :-?


  

Betrifft: AW: Alternativ würde auch Folgendes fktionieren, ... von: Andy
Geschrieben am: 21.10.2014 19:26:53

Hi @all

na Bravo und Danke erstmal

;-)


 

Beiträge aus den Excel-Beispielen zum Thema "Text ein/ausblenden"