Microsoft Excel

Herbers Excel/VBA-Archiv

ueberpruefen in zwei spalten

Betrifft: ueberpruefen in zwei spalten von: frank
Geschrieben am: 10.11.2014 09:31:33

https://www.herber.de/bbs/user/93647.xlsx

hallo zusammen,

ich muss in einer umfangreichen tabelle zwei spalten ueberpruefen und je nach ergebnis in einer dritten spalte etwas eintragen.
ich hoffe in beigefuegter datei wird klar, wie es aussehen soll.

ich wuerde mich ueber entsprechende tipps freuen.

im voraus fuer euere hilfe vielen dank.

  

Betrifft: AW: ueberpruefen in zwei spalten von: SF
Geschrieben am: 10.11.2014 10:00:09

Hola,

so?

=WENN(ZÄHLENWENNS($B$1:$B$10;B1;$C$1:$C$10;"")=ZÄHLENWENN($B$1:$B$10;B1);"fehlt";"")
Gruß,
steve1da


  

Betrifft: AW: ueberpruefen in zwei spalten von: frank
Geschrieben am: 10.11.2014 10:13:45

hallo steve1da,

danke erst mal.
in spalte B kann es jedoch vorkommen, dass in einer spaeteren zeile wieder vorherige werte vorkommen, bei denen in spalte C mal ein eintrag drin ist und mal nicht.
solange die werte in spalte B unterschiedlich sind funktionert deine formel. danach leider nicht mehr.
sorry, hatte ich vergessen mit anzugeben.
https://www.herber.de/bbs/user/93648.xlsx


  

Betrifft: AW: ueberpruefen in zwei spalten von: SF
Geschrieben am: 10.11.2014 10:25:30

Hola,

dir ist aber schon aufgefallen, dass meine Bereiche nur bis Zeile 10 gehen? ;-)

Gruß,
steve1da


  

Betrifft: AW: ueberpruefen in zwei spalten von: frank
Geschrieben am: 10.11.2014 10:37:17

ja, ist mir aufgefallen,

ich helfe mir jetzt mit einer extra spalte in der ich einfach einen zaehler hochzaehle, wenn sich die werte aendern und ueberpruefe dann nach der spalte.

vielen dank - hat mir einiges an arbeit erspart.


 

Beiträge aus den Excel-Beispielen zum Thema "ueberpruefen in zwei spalten"