Microsoft Excel

Herbers Excel/VBA-Archiv

ich weiß jetzt nicht ob ich damit übers Ziel...

Betrifft: ich weiß jetzt nicht ob ich damit übers Ziel... von: Thorben
Geschrieben am: 10.11.2014 14:38:32

Hallo ihr lieben,
die bösen natürlich auch!

Ich bin mir jetzt nicht ganz sicher ob ich mit meiner Frage vor ein paar Tagen übers Ziel hinausgeschossen bin. Falls ja bitte ich um Entschuldigung!

Es ging um dieses Thema (Suche!):
Matrix - Summewenns + Datum + Nummernabgleich

mit dieser Beispielmappe:
https://www.herber.de/bbs/user/93474.xlsx

Formellösung von Rudi Maintaire (nochmal Danke):
=SUMMEWENNS(BatchNr!$L:$L;BatchNr!$N:$N;"<"&A2;BatchNr!$N:$N;">="&B2;BatchNr!$F:$F;$A4)

Dazu hatte ich gefragt ob man das auch per VBA Lösen kann mit Scription Dic. oÄ.
da es mit der Formal zwar geht aber lange dauert und aufgrund toller Beispiele und Erfahrungen damit, nur eben nicht meine Liga ist!!!

Guckt doch noch mal rein bitte.

Da ich den Aufwand nicht schätzen kann und wenn es für eine Forumsfrage zu viel verlangt ist bitte ich euch um Entschuldigung und lege es ad-acta.

Trotzdem nochmal vielen Dank für alle bisherigen Hilfestellungen.

MfG
Thorben

  

Betrifft: AW: ich weiß jetzt nicht ob ich damit übers Ziel... von: fcs
Geschrieben am: 10.11.2014 16:55:19

Hallo Thorben,

eigentlich sollte die SUMMEWENNS-Funktion schneller sein als Umsetzungen per VBA.

Um wie viele Daten-Zeilen geht es denn maximal im Blatt "BatchNr" ?

Bei umfangreichen Änderungen/Ergänzungen in diesem Blatt sollte man den Berechnungsmodus vorrübergehend auf "Manuell" setzen.

Alternativ könnte man die Formeln im Blatt Statistik per Makro einfügen und durch ihre Werte ersetzen.

Gruß
Franz






  

Betrifft: hab es für mich jetz so gelöst... von: Thorben
Geschrieben am: 11.11.2014 09:15:54

Hallo Franz,

insgesamt sind es 5600 BatchNr. aus 465000 Zeilen.
Die Daten werden aus Access in Excel geschrieben.
Mein Gedanke ging in Richtung "OneClick" Lösung (also auch für nicht Excel Menschen)
Ich habe es jetzt für mich so gelöst das er die Datumskriterien
in der Quelle AutoFiltert, die sichtbaren in eine neue Tabelle schiebt und von dort aus liest.

Dann sind es nur noch ein paar tausend Zeilen und geht mit der "Rudi-Formel" schnell voran.

Trotzdem vielen Dank für die Rückmeldung

MfG
Thorben