Daten gliedern

Bild

Betrifft: Daten gliedern
von: Carl Fornia
Geschrieben am: 06.05.2015 17:42:43

Hallo zusammen,
nach längerer Recherche habe ich mich überwunden und frage Euch um Rat bei meiner Aufgabenstellung.
Ich möchte Daten gliedern von Zeilen in Spalten.
Beispiel:
ID Wert
1 25
1 25
1 50
2 50
2 50
Ziel soll so aussehen:
ID Wert1 Wert2 Wert3
1 25 25 50
2 50 50
Ideen?
Danke im Voraus.

Bild

Betrifft: AW: Daten gliedern
von: Hajo_Zi
Geschrieben am: 06.05.2015 17:51:42

Tabelle4

 ABCDEFGH
1IDWert IDWert1Wert2Wert3Wert4
2125 1252550 
3125 25050  
4150      
5250      
6250      
7HTTP://WWW.excelformeln.de/formeln.html?welcher=194  
8HTTP://WWW.excelformeln.de/formeln.html?welcher=28  

 verbundene Zellen 
A7:F7
A8:F8

verwendete Formeln
Zelle Formel Bereich N/A
D2{=INDEX(A:A;MIN(WENN(A2:A5<>"";ZEILE(2:5))))}$D$2 
E2:H3{=WENNFEHLER(INDEX($B:$B;KKLEINSTE(WENN($A$2:$A$6=$D2;ZEILE($2:$6));SPALTE()-4));"")}$E$2 
D3: D4{=WENNFEHLER(INDEX(A:A;VERGLEICH(1;(ZÄHLENWENN($D$2: D2;$A$2:$A$6)=0)*($A$2:$A$6<>"");0)+1);"")}$D$3 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.02 einschl. 64 Bit




Bild

Betrifft: oder mit VBA
von: Michael
Geschrieben am: 06.05.2015 18:08:28
Hallo zusammen,
ich habe die Beispielwerte incl. Überschriften in B2 bis C7 stehen.
Das Makro schreibt in die gleiche Zeile, aber weiter rechts (je nach dem, was in spalteLinks angegeben wird):

Sub gliedern()
von = 3
bis = Range("b2").End(xlDown).Row
zeile = von - 1
spalteLinks = 5
letzteID = Range("B" & von) - 5
For i = von To bis
  ID = Range("B" & i)
  If letzteID = ID Then
    spalte = spalte + 1
    Cells(zeile, spalte) = Range("C" & i)
  Else
    letzteID = ID
    zeile = zeile + 1
    spalte = spalteLinks
    Cells(zeile, spalte) = Range("B" & i)
    Cells(zeile, spalte + 1) = Range("C" & i)
    spalte = spalte + 1
  End If
Next
End Sub
Schöne Grüße,
Michael

Bild

Betrifft: AW: oder mit VBA
von: Carl Fornia
Geschrieben am: 06.05.2015 18:26:12
Wow - wird gleich morgen ausprobiert! Unfassbar, diese kurzen Reaktionszeiten.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Richtiges Anwenden der Replace Funktion"