Projektnr. erweitern

Bild

Betrifft: Projektnr. erweitern
von: Peter
Geschrieben am: 08.05.2015 12:33:17

Hallo,
in einer laaaaaangen Tabelle werden Projektnummern mit Unterprojekten dargestellt.
Spalte 1 Spalte 2
Hauptprojekt 30-01
Unterprojekt 30-01-01
Unterprojekt 30-01-02
Ich möchte in einer weiteren Tabellenspalte die Projektnummern der Unterprojekte wiederholen. Die Projektnummern der Hauptprojekte aber um -00 ergänzen.
Kann mir jemand sagen, wie ich das mit einer Formel hinkriege?
Gruß
Peter

Bild

Betrifft: AW: Projektnr. erweitern
von: Schliesser
Geschrieben am: 08.05.2015 13:00:08
Hallo
so?
Danach Spalte kopieren, Inhalte einfügen, Werte..
Tabelle1

 ABC
1Hauptprojekt30-0130-01-00
2Unterprojekt30-01-0130-01-01
3Unterprojekt30-01-0230-01-02

verwendete Formeln
Zelle Formel Bereich
C1 =WENN(LÄNGE(B1)=5;B1&"-00";B1) 

Tabellendarstellung in Foren Version 5.49


Gruß UweD

Bild

Betrifft: AW: Projektnr. erweitern
von: Udo
Geschrieben am: 08.05.2015 13:00:29
Hai,
mein Lösungsvorschlag:
Projektnummern in Spalte B, beginnend ab Zeile 1
Dann folgende Formel in C1

=WENN(LÄNGE(B1)<6;"";LINKS(B1;6)&"00"&RECHTS(B1;3))
Gruß
Udo

Bild

Betrifft: AW: Projektnr. erweitern
von: Kenny
Geschrieben am: 08.05.2015 13:04:03
Hi Peter,
Modul in VBA einfügen und das hier reinschreiben:


Function x(nummer As String)
If Len(nummer) = 5 Then
    x = nummer & "-00"
Else
    x = nummer
End If
End Function
Anschließend in die Zelle:

=x(A2)

und runterziehen
Hoffe es klappt!

Bild

Betrifft: AW: Projektnr. erweitern
von: Peter
Geschrieben am: 08.05.2015 13:51:13
Danke an alle, jede der Lösungen funktioniert hervorragend.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Projektnr. erweitern"