Datum vervollständigen

Bild

Betrifft: Datum vervollständigen
von: Alexander
Geschrieben am: 12.06.2015 11:50:36

Hallo Liebe Excel Freunde,
ich habe ein mehr oder weniger schwieriges Problem, bei der Vorformatierung einer Excel-Datei. Ich möchte von einer Excel Datei auf eine andere zugreifen und in dieser Formatierungen vornehmen.
Die Formatierungen sehen wie folgt aus:
Ich habe eine Datumspalte und 5 dazugehörige Zahlenspalten. Das ganze ingesamt 11 mal. Zu beachten ist, dass in den Datumsspalten einige Tage fehlen und die 11 Datumsspalten unterschiedliche Tage beinhalten.
Die Formatierung soll am Ende so aussehen, dass man das früheste und späteste Datum aus den 11 Spalten rausgreift und die Tage dazwischen auffüllt. Wichtig ist, dass die Tage die aufgefüllt werden mit den Daten des Vortages (oder mit den Daten des daruffolgenden Tages falls kein vorheriges Datum vorhanden ist) gefüllt werden, d.h.
Nummer 1
Date---------open---high---low---last---volume
01.01.1980----1------1------1------10------5
03.01.1980----1------2------3------15------6
Nummer11
Date---------open---high---low---last---volume
31.12.1979----5------4------1------1------60
03.01.1980----5------3------1------3------61
Ergebnis:
Nummer 1
Date---------open---high---low---last---volume
31.12.1979----1------1------1------10------5
01.01.1980----1------1------1------10------5
02.01.1980----1------1------1------10------5
03.01.1980----1------2------3------15------6
Nummer11
Date---------open---high---low---last---volume
31.12.1979----5------4------8------9------60
01.01.1980----5------4------8------9------60
02.01.1980----5------4------8------9------60
03.01.1980----5------3------1------3------61
Ich habe eine Beispieldatei hochgeladen https://www.herber.de/bbs/user/98163.xlsx , in der die Struktur etwas klarer ist. Abgesehen von der Länge soll natürlich die Formatierung dieselbe bleiben und das Ergebnis in eine neue Tabelle geschrieben werden. (Schaltjahre sollen natürlich auch berücksichtigt werden)
Ich würde mich wirklich sehr freuen, wenn mir jemand helfen könnte, denn ich habe einfach zu wenig Excel Erfahrung, sodass ich momentan alles per Hand kopiere und das einfach zu lange dauert.^^
Alexander

Bild

Betrifft: einfach hochzählen und vergleichen ...
von: der neopa C
Geschrieben am: 12.06.2015 17:49:14
Hallo Alexander,
... am Beispiel von "Nummer 1" (andere analog); Formel B5 nach unten kopieren und C4 nach rechts und unten:

 ABCDEFG
1       
2 Nummer 1     
3 DateOPENHIGHLOWLASTVOLUME
4 01.01.1980111105
5 02.01.1980111105
6 03.01.1980222115
7 04.01.1980333125
8 05.01.1980333125
9 06.01.1980333125
10 07.01.1980444135
11 08.01.1980555145

Formeln der Tabelle
ZelleFormel
B4=Beispiel!A6
C4=WENN(B4="";"";VERWEIS($B4;Beispiel!$A:$A;Beispiel!B:B))
B5=WENN(MAX(B$4:B4)>MAX(Beispiel!A:A); "";B4+1)
C5=WENN(B5="";"";VERWEIS($B5;Beispiel!$A:$A;Beispiel!B:B))
B6=WENN(MAX(B$4:B5)>MAX(Beispiel!A:A); "";B5+1)
C6=WENN(B6="";"";VERWEIS($B6;Beispiel!$A:$A;Beispiel!B:B))


 ABCDEF
4Nummer 1     
5DateOPENHIGHLOWLASTVOLUME
601.01.1980111105
703.01.1980222115
804.01.1980333125
907.01.1980444135
1008.01.1980555145
1109.01.1980666155
1210.01.1980777165
1311.01.1980888175


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: einfach hochzählen und vergleichen ...
von: Alexander
Geschrieben am: 15.06.2015 14:27:35
Hallo Werner,
erstmal danke für deine Lösung und sorry für die späte Antwort. Die Formeln funktionieren ganz gut, nur habe ich das Problem, dass mein Datensatz sehr sehr lang ist. Ein Makro das genau das macht was du mit Formeln geschafft hast währe echt traumhaft. Habe es selber versucht, nur scheitert es, da meine VBA Kentnisse einfach zu schlecht sind. :-(
Gruß Alexander

Bild

Betrifft: VBA
von: Michael
Geschrieben am: 15.06.2015 20:59:53
Hi Alexander,
anbei Tabelle incl. VBA-Code.
Ist alles andere als optimiert, aber er tut (so, wie ich Deine Frage verstanden habe), und für mehr hab ich grad keinen Kopf.
Die Datei: https://www.herber.de/bbs/user/98227.xlsm
Happy Exceling,
Michael

Bild

Betrifft: AW: VBA
von: Alexander
Geschrieben am: 16.06.2015 17:47:35
Hallo Michael,
vielen, vielen Dank! Es funktioniert einwandfrei und auch noch recht schnell! Ich muss nun nur noch den Code so anpassen das er eine andere bestehende Excel Datei verändert, aber das sollte ich selbst hinbekommen. Falls nicht werde ich mich wieder melden. ;)
Vielen Dank nochmals.
Gruß Alexander

Bild

Betrifft: ist Recht, danke für die Rückmeldung owT
von: Michael
Geschrieben am: 17.06.2015 15:58:14


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datum vervollständigen"