doppelte nicht mit rechnen

Bild

Betrifft: doppelte nicht mit rechnen
von: Armin
Geschrieben am: 16.06.2015 09:01:19

Hallo zusammen,
Ich habe eine Tabelle in der in:
Spalte A Namen
Spalte B Nummern ( Lieferschein )
Spalte C Gewicht ( Zahlen )
es gibt noch zich weiter Spalten mit Angaben, die hier aber nichts zur Sache tun.
Jetzt möchte ich mit einer Zählenwenn wissen welcher Name wie oft über ein bestimmtes Gewicht kommt.
=ZÄHLENWENNS(a:a;Name;c:c;">=44000";c:c;"<45000")
So weit so gut.
Jetzt habe ich das Problem, dass der Lieferschein doppelt vorkommen kann und somit dann auch das Gewicht doppelt ist.
Dennoch darf jeder Lieferschein nur einmal gezählt werden.

Bild

Betrifft: das geht mit SUMMEWENNS() nicht ....
von: der neopa C
Geschrieben am: 16.06.2015 10:21:10
Hallo Armin,
... z.B. so würde es gehen:

=SUMMENPRODUKT((A1:A99="Name")*(VERGLEICH(A1:A99&B1:B99;A1:A99&B1:B99;)=ZEILE(A1:A99)) *(C1:C99>=44000)*(C1:C99<45000))

ergänzender Hinweis: Bei evtl. notwendiger Formelanpassung, beschränke den auszuwertenden Zeilenbereich (in meiner Formel auf 99 Zeilen) auf das max. erforderliche.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: das geht mit SUMMEWENNS() nicht ....
von: Armin
Geschrieben am: 16.06.2015 11:25:56
Ich habe das eben in einer kleinen Hilfstabelle versucht, funktioniert super.
Aber in meiner großen Tabelle bekomme ich immer den Fehler WErt nicht vorhanden.
Hier sind die Spalten andere, aber das habe ich alles angepasst.
=SUMMENPRODUKT(Buchungsliste!Z1:Z3257=A84)*(VERGLEICH(Buchungsliste!Z1:Z3257&Buchungsliste!D1:D3257; Buchungsliste!Z1:Z3257&Buchungsliste!D1:D3257;)=ZEILE(Buchungsliste!Z1:Z3257)) *(Buchungsliste!M1:M3257>=44000)*(Buchungsliste!M1:M3257<45000)
ich kann den Fehler nicht finden, könnte mir nochmal jemand helfen bitte.
Gruß Armin

Bild

Betrifft: Klammersetzung ist nicht korrekt ...
von: der neopa C
Geschrieben am: 16.06.2015 11:32:18
Hallo Armin,
... hier meinerseits ungetestet, so: =SUMMENPRODUKT((Buchungsliste!Z1:Z3257=A84)*(VERGLEICH(Buchungsliste!Z1:Z3257&Buchungsliste!D1:D3257; Buchungsliste!Z1:Z3257&Buchungsliste!D1:D3257;)=ZEILE(Buchungsliste!Z1:Z3257)) *(Buchungsliste!M1:M3257>=44000)*(Buchungsliste!M1:M3257<45000))
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Klammersetzung ist nicht korrekt ...
von: Armin
Geschrieben am: 16.06.2015 11:36:41
Hallo Werner,
das war es leider nicht.
Wie gesagt, die erste Formel funktioniert auch in meiner Test-Liste ohne Probleme.
nur in der Großen leider nicht.
Gruß Armin

Bild

Betrifft: dann kann es verschiedene Ursachen haben ...
von: der neopa C
Geschrieben am: 16.06.2015 11:39:45
Hallo Armin,
... kannst Du einen relevanten kleinen Dateiauszug hier als Datei einstellen oder notfalls mir zukommen lassen?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Klammersetzung ist nicht korrekt ...
von: Armin
Geschrieben am: 16.06.2015 11:43:20
JUHU Problem gelöst.
Ich hatte in der Namens Liste einen Fehler (#NV) drinnen.
Da die über nen Sverweis zusammengestellt wird.
Kaum habe ich das mit nemm Wennfehler... behoben geht die Formel auch =)
Vielen Vielen Dank.
Gruß Armin

Bild

Betrifft: AW: Klammersetzung ist nicht korrekt ...
von: Armin
Geschrieben am: 16.06.2015 11:51:57
Aber schon tut sich die nächste Frage auf,
gibt es noch die Möglichkeit den Bereich flexibel zu halten d.H.
nicht Z1:Z3257
sondern halt von Z1 bis Ende
da ich die Formel jeden Monat verwenden muss.
Jeden Monat ändern wäre ja nicht wirklich Excel Like =)
Gruß Armin

Bild

Betrifft: auch da geht ...
von: der neopa C
Geschrieben am: 16.06.2015 12:06:50
Hallo Armin,
... Du kannst den letzten Datenwert in Spalte Z ermitteln und dessen Zellenwert über ein zusätzliches INDEX() in die Formel einbauen.
Was für Werte stehen den in Spalte Z , Zahlen- oder Textwerte. Gibt es zusätzliche Leerzeilen in Spalte Z zwischenrein?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: auch da geht ...
von: Armin
Geschrieben am: 16.06.2015 13:17:57
In Spalte Z stehen die Namen.
zum Beispiel Max Mustermann
aber hier gibt es keine Leer Zeilen.
Gruß Armin

Bild

Betrifft: unter der Voraussetzung ...
von: der neopa C
Geschrieben am: 17.06.2015 17:38:28
Hallo Armin,
... musst Du nur jede Bereichsangabe in der Formel analog wie am folgenden Beispiel aufgezeigt ersetzen:
... Buchungsliste!D1:D3257;)... durch Buchungsliste!D1:INDEX(Buchungsliste!D:D;ANZAHL2(Buchungsliste!Z:Z));)
Verständlich?
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "doppelte nicht mit rechnen"