Neuling

Bild

Betrifft: Neuling
von: Hans
Geschrieben am: 29.06.2015 02:18:26

Hallo zusammen,
Ich stell mich mal kurz vor. Bin der Hans und 56 Jahre alt, komme aus dem schönen Allgäu und lerne gerade Excel.
Meine Frage zu verstehen.
D8=1-05-10-36
Jetzt hab ich mit der Formel:
M7=Teil(D8;3;2)
Ergebnisse 05 in der Zelle M7
So wäre das scho richtig.
Jetzt kommt meine nächste Formel
M6=Zählenwenn(D2:D100;"05")
Ich möchte gerne, das es eine Formel gibt mit ZählenWenn und Teil.
So das ich meine Nummer Splitter (05) und dann alle zahlen mit 05 zähle.
Könnt ihr mit Bitte erklären wie ich Zählenwenn und teil zusammenkomprimiere!!!
Lieben Dank
HANS aus Allgäu

Bild

Betrifft: =ZÄHLENWENN(D2:D100;"*05*")
von: WF
Geschrieben am: 29.06.2015 07:14:23
.

Bild

Betrifft: Zählenwenn(Teil)
von: RPP63
Geschrieben am: 29.06.2015 07:16:14
Hallo Hans!
Willkommen im Forum!
Du kannst mit Platzhaltern zählen.
Der Asterisk * steht für beliebige Zeichen, das Fragezeichen ? für ein einzelnes beliebiges Zeichen.
Deshalb dürfte die Formel in B2 für Dich die geeignete sein?

 AB
11-05-10-363
214-05-1-141
311-12-11-5 
42-04-05-7 

Formeln der Tabelle
ZelleFormel
B1=ZÄHLENWENN(A:A;"*-05-*")
B2=ZÄHLENWENN(A:A;"?-05-*")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Ralf

Bild

Betrifft: AW: Zählenwenn(Teil)
von: Thom
Geschrieben am: 29.06.2015 19:44:58
Hallo
ich finde diesen Beitrag interessant, und hab gleich die Formel benutzt
@Hans: Was habt ihr Lagersystem? Denn wir haben auch solche Greifplätze.
Meine Frage an die Excelfreaks,
Ich hab die Formel benutzt =ZÄHLENWENN(A:A;"?-07-*")
Könnt ihr bitte mal meine Liste anschauen und evtl die Formel verkürzen, da noch andere Lagerbereiche dazukommen (Q5 und T5 )
Der Lagerbereich befindet sich in K11 und K13
https://www.herber.de/bbs/user/98548.xlsm
Was ich nicht hinbekomme ist im Lagerbereich die unten und oben zuzählen.
O5 wäre 1
P5 wäre 8
R5 wäre 1
S5 wäre 1
Nur bei Werte G1
Hoffe ihr findet was.
Danke euch
LG Thom

Bild

Betrifft: AW: Neuling
von: MCO
Geschrieben am: 29.06.2015 07:28:03
Hallo Hans!
Willkommen in der Welt von Excel!
Leider kann ich das gewünschte Ergebnis nur schwer anhand deiner Beschreibung nachvollziehen.
Das Ergebnis, das ich erhalte in D8 ist -50, nicht 0,5
"TEIL" liefert dir auch keine Zahl, sondern den Teil eines Textes. Excel wird zwar mit dem Zahlenwert rechnen (bei "05": 5) wird dir aber beispielsweise bei Suchen oder Auswertungen nur die TEXTE zählen.
Deine eigentliche Frage ist wie folgt zu beantworten:
Ersetze das Ergebnis von M7 durch die Formel. Das sieht dann so aus:
M6=Zählenwenn(D2:D100;Teil(D8;3;2))
Um die Texte und die Zahlen zu zählen kannst du folgende Formeln in D13 oder D14 verwenden (Bereiche anpassen!), wobei du mit D14 wahrscheinlich besser zurechtkommst (siehe unten: Hinweise zur Matrix-Formel).

Tabelle1

 ABCD
1    
2    
3    
4    
5    
6    
7    
8   -50
9    
10    
11    
12    
13 13 '05
14 13 '05
15   '05
16   '05
17   '05
18   '05
19   '05
20   '05
21   '05
22   5
23   5
24   5
25   5

verwendete Formeln
Zelle Formel Bereich N/A
D8=1-5-10-36  
B13{=SUMME(--(D13: D26={"05".5}))}$B$13 
B14=ZÄHLENWENN(D13: D26;{"05".5})  
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit


Als grundsätzlichen Tip kann ich dir noch folgenes raten:
Ein Bild (besser: Tabelle) sagt mehr als 1000 Worte. Bereinige Deine Tabelle von Daten, die keinen was angehen, dann hochladen. Deine Aufgabenstellungen werden mit der Zeit zu komplex werden, als das sie jemand nachvollziehen oder nachbauen wollte.
Viel Erfolg!
Gruß, MCO

Bild

Betrifft: WoW
von: Hans
Geschrieben am: 30.06.2015 00:38:17
Guten Abend ,
Ersteinmal danke für die nette Aufnahme.
Möchte mich herzlich bedanken für die ganzen Antworten. Hat alles super geklappt.
Thom wir arbeiten mit Wamas ein Österreich- Programm.
DANKE und liebe Grüße aus dem Allgäu
Hans

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Aufruf der Druckseite abfangen"