Matrix ordnen

Bild

Betrifft: Matrix ordnen
von: wizard
Geschrieben am: 08.07.2015 16:16:06

Hallo zusammen,
habe folgendes Probelm das ich gerne mit eurer Hilfe lösen würde.
Es existiert stark vereinfacht eine Matrix die folgendermaßen aufgebaut ist:
02.01.2000 Unternehmen123 Unternehmen253 Unternehmen536
03.01.2000 Unternehmen253 Unternehmen536 Unternehmen666
04.01.2000 Unternehmen536 Unternehmen652 Unternehmen111
Nun möchte ich dei Matrix so ordnen, dass gleiche Unternehmen untereinander erscheinen:
02.01.2000 Unternehmen123 Unternehmen253 Unternehmen536
03.01.2000 -----Leerzeile------ Unternehmen253 Unternehmen536 Unternehmen666
04.01.2000 -----Leerzeile------ -----Leerzeile------ Unternehmen536 -----Leerzeile------ Unternehmen652 Unternehmen111
Ist das per VBA lösbar und wenn ja wie? Danke vorab!

Bild

Betrifft: warum so? ...
von: der neopa C
Geschrieben am: 08.07.2015 16:22:15
Hallo,
... warum nicht einfach die Unternehmen in einer Überschriftszeile alle listen und dann aus Deiner Datentabelle in die Ergebnistabelle jeweils in entsprechende Zelle z.B. ein "x" zuordnen?
Das ist doch viel übersichtlicher und lässt sich besser weiter auswerten und könnte man übrigens auch mittels einer Formel realisieren.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: warum so? ...
von: wizard
Geschrieben am: 08.07.2015 16:48:43
Wie meinst du das genau? Die Ursprungsmatrix ist leider aus einer Software vorgegeben.

Bild

Betrifft: nun z.B. wie folgt ...
von: der neopa C
Geschrieben am: 08.07.2015 17:32:32
Hallo,
... nachfolgende Formel einfach ziehend nach rechts und unten kopieren:

 ABCDEFGHIJKL
102.01.2000Unternehmen123Unternehmen253Unternehmen536 DatumUnternehmen111Unternehmen123Unternehmen253Unternehmen536Unternehmen652Unternehmen666
203.01.2000Unternehmen253Unternehmen536Unternehmen666 02.01.2000 xxx  
304.01.2000Unternehmen536Unternehmen652Unternehmen111 03.01.2000  xx x
4     04.01.2000x  xx 
5            

Formeln der Tabelle
ZelleFormel
G2=WENN(SUMMENPRODUKT(($A$1:$A$99=$F2)*($B$1:$D$99=G$1)); "x";"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nun z.B. wie folgt ...
von: wizard
Geschrieben am: 08.07.2015 18:53:52
Ich möchte Renditewerte aus einer anderen Tabelle auf die jeweilige Stelle mappen. deswegen sollte nicht nur X sondern der Unternehmensname/nummer da stehen.

Bild

Betrifft: mir noch immer unklar ...
von: der neopa C
Geschrieben am: 09.07.2015 13:03:33
Hallo,
... was Du als Begründung für Deine Zielstellung anführst, lässt sich für mich mangels Daten nicht nachvollziehen. Sei es drum. Zumindest solltest Du noch eindeutig klären, ob Du mit Deinen Angaben: "-----Leerzeile------" wirklich Leerzeile meinst oder doch Leerzelle?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mir noch immer unklar ...
von: wizard
Geschrieben am: 09.07.2015 15:56:54
Leerzellen sind korrekterweise gemeint

Bild

Betrifft: nun dann wird es etwas komplexer ...
von: der neopa C
Geschrieben am: 09.07.2015 16:45:39
Hallo,
... obwohl ich noch immer nicht weiß, wofür das Ergebnis gut sein soll, hier eine Möglichkeit dies mittels Formel(n) zu lösen.
Formel G1 bis I1 ziehend kopieren und die Formel G2 nach unten und rechts (wobei je mehr Datensätze, natürlich immer weiter nach rechts)

 ABCDEFGHIJKL
102.01.2000Unternehmen123Unternehmen253Unternehmen536 02.01.2000Unternehmen123Unternehmen253Unternehmen536   
203.01.2000Unternehmen253Unternehmen536Unternehmen666 03.01.2000 Unternehmen253Unternehmen536Unternehmen666  
304.01.2000Unternehmen536Unternehmen652Unternehmen111 04.01.2000  Unternehmen536 Unternehmen652Unternehmen111
4            

Formeln der Tabelle
ZelleFormel
G1=WENN(B1="";"";B1)
G2=WENNFEHLER(INDEX(G:G;AGGREGAT(15;6;VERGLEICH($B2:$D2;G$1:G1;); 1)); WENN(SUMMENPRODUKT(N(LÄNGE(G$1:G1)>0))+(SUMMENPRODUKT(N(LÄNGE($F2:F2)>0))=4); "";WENN(SUMMENPRODUKT(N(LÄNGE($F2:F2)<4)); INDEX(2:2;SUMMENPRODUKT(N(LÄNGE($F2:F2)>1))+1); "")))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Matrix ordnen"