Länge einer Eingabe

Bild

Betrifft: Länge einer Eingabe
von: Andreas
Geschrieben am: 15.07.2015 16:02:45

Hallo an alle hier im Forum,
vielleicht könnt ihr mir ja helfen.
Ich gebe in einer Zelle einen wert ein. Dieser hat entweder
das Format 3D01000123 oder F123456.
Jetzt möchte ich wenn die Eingabe 10-stellig ist, soll sie in Zelle B10 geschrieben werden, und wenn sie nur 7-stellig ist soll sie in Zelle D10.
Könnte mir jemand helfen, wie die Formatierung bzw. die Formel für die beiden Zellen sein muss.
Wäre nett von Euch. Ich danke schon einmal im voraus.
mfg
Andreas

Bild

Betrifft: ich verstehe das nicht, wofür das so? und ...
von: der neopa C
Geschrieben am: 15.07.2015 16:14:59
Hallo Andreas,
... und wo erfolgt die Eingabe? In a1? Es würde also die einmalige Eingabe entweder in D10 oder in B10 erscheinen sollen? Dann einfach =WENN(LÄNGE(A1)=10;A1;"") bzw. =WENN(LÄNGE(A1)=7;A1;"") Dss Format der Zellen wäre normal Standard. Wofür soll das gut sein?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: ich verstehe das nicht, wofür das so? und ...
von: Andreas
Geschrieben am: 15.07.2015 16:22:51
Hallo Werner,
stimmt, ich habe die Eingabe Zelle vergessen. Diese kann ich mir aber ändern.
ich benutze ein Eingangsprotokoll, welches nur EIN Feld hat, zur Eintragung einer Maschinenkennung.
Beim weiteren bearbeiten, möchte ein Partner von uns, das die Eingabe in seinem Formular zwei verschiedenen Felder, so oder so, benutzt werden.
Kann ich halt nicht ändern.
dafür ist das.
ich werde dieses ausprobieren.
Ich danke dir für deine schnelle Hilfe.
schönen Tag noch
Andreas

Bild

Betrifft: AW: ich verstehe das nicht, wofür das so? und ...
von: Andreas
Geschrieben am: 15.07.2015 16:41:30
Hallo Werner
habe es soeben ausprobiert und funktioniert einwandfrei.
Danke nochmal
Andreas

Bild

Betrifft: Länge einer Eingabe in A10
von: Matthias L
Geschrieben am: 15.07.2015 16:22:13
Hallo
Bsp für A10

Option Explicit
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column = 1 And Target.Row = 10 Then
 Select Case Len(Target)
 Case Is = 10
  Target.Offset(0, 1) = Target
 Case Is = 7
  Target.Offset(0, 3) = Target
 End Select
End If
End Sub

Wobei Du die 0 vor dem Komma bei Offset auch weglassen kannst.


 ABCD
9Eingabe10 stellen 7 Stellen
10125äölokljuztre3s 125äölo


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: Länge einer Eingabe in A10
von: Andreas
Geschrieben am: 15.07.2015 16:44:28
Hallo Matthias
danke dir für deine Mühen.
Ich hab es mir der Hilfe von Werner, für mich Laien überschaubarer hinbekommen.
Danke dir nochmals
schönen Abend noch
Andreas

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Länge einer Eingabe "