MITTELWERT WENN

Bild

Betrifft: MITTELWERT WENN
von: Helmuth
Geschrieben am: 18.07.2015 12:09:11

Hallo,
beiliegende Tabelle gibt im Feld I1 den Mittelwert der Bereiche D1:E2 und G1:G2 ausgeben, wenn entsprechend in den Spalten A und B der Wert 1 hinterlegt wird.
Sobald ich jedoch in die Zelle A1 den Wert 2 eingebe, sollte im Feld I1 die Fehlermeldung #DIV/O! erscheinen, stattdessen erhalte jedoch einen nicht erklärbaren Mittelwert.
https://www.herber.de/bbs/user/98913.htm

Bild

Betrifft: Deine Formel ergibt korrekte Ergebnisse ...
von: der neopa C
Geschrieben am: 18.07.2015 12:59:59
Hallo Helmuth,
... bloß wie Du schreibst, willst Du offensichtlich etwas anders ermitteln (warum auch immer gerade so, lässt sich für mich momentan nicht erkennen) Dann muss jedenfalls die Formel auch anders lauten.

 ABCDEFGHI
1117713445  
2112224556 3,50

Formeln der Tabelle
ZelleFormel
I2{=MITTELWERT(WENN((SPALTE(D1:G2)<>6)*(SUMME(N(A1:B2={1.1;1.1}))=4); D1:G2))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Meinst Du es so?
Gruß Werner
.. , - ...

Bild

Betrifft: Korrektur einer Aussage ...
von: der neopa C
Geschrieben am: 18.07.2015 13:18:50
Hallo,
... meine Aussage: "...willst Du offensichtlich etwas anders ermitteln" ist falsch, denn Du willst ja den Mittelwert von {D1:E2;G1:G2} ermitteln. Oder? u Bloß die Bedingung für die Du diesen Wert ermitteln willst (so wie ich es aus Deinen Aussagen und Deiner Formel entnommen und interpretiert habe) müssen anders definiert werden und das hab ich getan. Mein Vorschlag dazu liegt vor.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "MITTELWERT WENN"