Zählen...

Bild

Betrifft: Zählen...
von: Chris
Geschrieben am: 19.08.2015 09:26:17

Hallo Forum,
ich möchte per Formel folgendes umsetzen.
In Spalte B steht Datum als Text formatiert.
In Spalte L stehen veschiedene Zahlen im Format X.X
Zähle für alle "2.2" Angabe in Spalte L die Anzahl der Datumsangaben in Spalte B:
z.B:
2.2
01.01.12 2.2
1.0
1.2
01.02.13 2.2
Ergebnis: 2 (2x Datum bei 2.2)
Wie löst man so etwas per Formel?
Gruß
Chris

Bild

Betrifft: AW: nutze ZÄHLENWENN() ... owT
von: ... neopa C
Geschrieben am: 19.08.2015 09:45:00
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nutze ZÄHLENWENN() ... owT
von: Chris
Geschrieben am: 19.08.2015 12:13:40
Hallo Werner,
nein zählenwenn zählt die Anzahl nicht leerer Zellen....
jmd ein Vorschlag?
Chris

Bild

Betrifft: AW: nutze ZÄHLENWENN() ... owT
von: selli
Geschrieben am: 19.08.2015 12:28:08
hallo chris,
=SUMMENPRODUKT((L1:L2000="2.2")*(B1:B2000=LÄNGE(B1:B2000)>3))
die bereiche ggf. anpassen.
gruß
selli

Bild

Betrifft: vorschlag geht so nicht e.o.m.
von: selli
Geschrieben am: 19.08.2015 12:32:35


Bild

Betrifft: so
von: selli
Geschrieben am: 19.08.2015 12:37:10
hallo chris,
=SUMMENPRODUKT((L1:L2000="2.2")*(LÄNGE(B1:B2000)>3)*1)
gruß
selli

Bild

Betrifft: AW: ich wollte ZÄHLENWENNS() schreiben ...
von: ... neopa C
Geschrieben am: 19.08.2015 17:26:36
Hallo Chis,
... sorry, natürlich nicht ZÄHLENWENN() sondern ZÄHLENWENNS() z.B. so: =ZÄHLENWENNS(I:I;"2.2";B:B;"<>"&"")
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "VBA Activen Bereich für resize in Range wählen"