Aggregierets Diagramm

Bild

Betrifft: Aggregierets Diagramm
von: Michael
Geschrieben am: 24.11.2015 16:09:54

Hallo zusammen,
Damit mein Problem verständlich wird habe ich euch ein kleines xlsx hochgeladen: https://www.herber.de/bbs/user/101772.xlsx
Ich habe also ein Arbeitsblatt mit mehren Tabellen, die ähnliche Daten mit jeweils einem Liniendiagramm enthalten (Tabelle 1-3). Je Tabelle habe ich ein Datum und einen dazugehören Zahlenwert. In der Tabelle "Zusammenfassung" benötige ich ein Liniendiagramm (oder auch erst mal eine Zwischentabelle, aus der ich mir das Diagramm dann basteln kann), welches mit den Verlauf der Zahlenwerte aller Tabellen aggregiert darstellt. Wichtig ist dabei, dass 1. die Sortierung nach Datum beibehalten wird und 2. ich in den Tabellen 1-3 weitere Zeilen hinzufügen kann und diese auch automatisch in der Zusammenfassung auftaucht.
Ist so etwas möglich?
Vielen dank schon mal,
Michael

Bild

Betrifft: AW: mit INDEX() und AGGREGAT() und ...
von: ... neopa C
Geschrieben am: 24.11.2015 16:54:14
Hallo Michael,
... und am einfachsten mit zwei Hilfsspalten (ich hab diese frei in H:I gewählt).
Nachfolgende Formeln einfach ziehend weit genug nach unten kopieren. Formeln H dann noch nach Spalte I. In den drei Datentabellen können beliebig Werte ein- und angefügt werden. Die Datenzuordnung wie Sortierung bleibt davon unberührt.
Das Diagramm bastelst Du ja selbst auf Basis der Daten in A:B

 ABCDEFGHI
1DatumZahl     Hilfsspalten
223.11.20155     11.11.20151
323.11.20150     10.11.20151
423.11.20150     10.11.20151
523.11.201598     10.11.20151
623.11.20155     10.11.20151
723.11.20150     10.11.20151
823.11.20150     10.11.20151
923.11.20150     10.11.20151
1023.11.20150     10.11.20151
1123.11.20150     10.11.20151
1223.11.20150     10.11.2015-17
1311.11.20151     10.11.20151
1410.11.20151     13.10.20151
1510.11.20151     13.10.20151
1610.11.20151     13.10.20151
1710.11.20151     13.10.20151
1810.11.20151     13.10.20151

Formeln der Tabelle
ZelleFormel
A2=WENNFEHLER(AGGREGAT(14;6;H:H;ZEILE(A1)); "")
B2=WENN(A2="";"";INDEX(I:I;AGGREGAT(15;6;ZEILE(A$1:A$999)/(H$1:H$999=A2); ZÄHLENWENN(A$2:A2;A2))))
H2=WENN(ZEILE(A1)>ANZAHL(Tabelle1!A:A)+ANZAHL(Tabelle2!$A:$A)+ANZAHL(Tabelle3!$A:$A); "";WENN(ZEILE(A1)>ANZAHL(Tabelle1!$A:$A)+ANZAHL(Tabelle2!$A:$A); INDEX(Tabelle3!A:A;1+ZEILE(A1)-ANZAHL(Tabelle1!$A:$A)-ANZAHL(Tabelle2!$A:$A)); WENN(ZEILE(A1)>ANZAHL(Tabelle1!$A:$A); INDEX(Tabelle2!A:A;1+ZEILE(A1)-ANZAHL(Tabelle1!$A:$A)); INDEX(Tabelle1!A:A;1+ZEILE(A1)))))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit INDEX() und AGGREGAT() und ...
von: Michael
Geschrieben am: 25.11.2015 10:21:45
Hallo Werner,
vielen Dank für deine Hilfe, das funktioniert tatsächlich wunderbar. Ich musste nur eine Kleinigkeit ändern. Da ich mit formatierten Tabellen habe erkennt Excel die Kopfzeile und beim Index musste die die "+1" wegnehmen. Irre Formel, danke noch mal.
Gruß,
Michael

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Aggregierets Diagramm"