Microsoft Excel

Herbers Excel/VBA-Archiv

Jahreskalender wochenweise


Betrifft: Jahreskalender wochenweise von: amel2002
Geschrieben am: 25.04.2017 10:18:12

Hallo ,

ich suche einen Kalender, in dessen Spalten A (und B) jeweils die Datumsangaben der jeweiligen Arbeitswochen (Mo bis Fr) stehen. Die Spalten sollen sich nach eingabe der Jahreszahl automatisch berechnen.
etwa so:
===========================================================
2017

02.01 - 06.01.
09.01 - 13.01.
16.01. -20.01.
...
====================================================

  

Betrifft: AW: Jahreskalender wochenweise von: Michael (migre)
Geschrieben am: 25.04.2017 10:48:17

Hallo!

So in der Art: https://www.herber.de/bbs/user/113095.xlsx ?

LG
Michael


  

Betrifft: AW: Jahreskalender wochenweise von: UweD
Geschrieben am: 25.04.2017 11:03:53

Hallo ihr zwei


für manche Jahre ( z.B. 2015) fehlt noch Zeile 56 unten.

kann z.B. so sein.



Tabelle1

 AB
5521.12.201525.12.2015
5628.12.201501.01.2016

verwendete Formeln
Zelle Formel Bereich N/A
A55=DATUM($A$1;1;7*(ZEILE()-3)-3-WOCHENTAG(DATUM($A$1;;);3))  
B55=A55+4  
A56=WENN(JAHR(DATUM($A$1;1;7*(ZEILE()-3)-3-WOCHENTAG(DATUM($A$1;;);3)))>JAHR(A55);"";DATUM($A$1;1;7*(ZEILE()-3)-3-WOCHENTAG(DATUM($A$1;;);3)))  
B56=WENN(A56<>"";A56+4;"")  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 21.10 einschl. 64 Bit




LG UweD


  

Betrifft: AW: Was interessiert mich... von: Michael (migre)
Geschrieben am: 25.04.2017 11:08:49

...meine blöde vergessene Woche von vor 2 Jahren?
Hat wohl schon Churchill gesagt... ;-)

Danke UweD für's Ergänzen.

LG
Michael


  

Betrifft: falls Churchill 2018 noch leben würde, ... von: UweD
Geschrieben am: 25.04.2017 11:25:08

.. dann hätte er nächstes Jahr auch das Problem. :-)


LG UweD


  

Betrifft: AW: was dann wohl sein kleinstes wäre ;-p, owT von: Michael (migre)
Geschrieben am: 25.04.2017 11:27:10




  

Betrifft: AW: was dann wohl sein kleinstes wäre ;-p, owT von: amel2002
Geschrieben am: 25.04.2017 11:30:30

Danke für die Hilfe, genau das wars


Beiträge aus den Excel-Beispielen zum Thema "Jahreskalender wochenweise"