Microsoft Excel

Herbers Excel/VBA-Archiv

Auswahlgültigkeit per vba


Betrifft: Auswahlgültigkeit per vba von: Der Uwe
Geschrieben am: 26.05.2017 20:37:15

Hi.

Brauche mal einen Spezialisten.

folgender Tabelleaufbau:



 	A	B	C	D	E	F
1	Auswahl				Möglich	gesperrt
2					AA01	
3					AA02	
4					AA03	G
5					AA04	
6					AA05	G
7					AA06	
8					AA07	
9					AA08	
10					AA09	
11					AA10	

Ich möchte den Zellen unter Auswahl eine Datenüberprüfung zuweisen.

Das geht ja normalerweise über
° Daten, Datenüberprüfung
° Zulassen: Liste
° und dann den Quellbereich E2:E100 angeben.

Das ganze will ich dann noch per VBA machen

So ginge das, wenn es eine herkömmliche Liste ist.
Sub Makro11()
    With Range("A2").Resize(1, 100).Validation
        .Delete
        .Add Type:=xlValidateList, AlertStyle:=xlValidAlertStop, Operator:= _
            xlBetween, Formula1:="=$E2:$E100"
        .IgnoreBlank = True
        .InCellDropdown = True
        .InputTitle = ""
        .ErrorTitle = ""
        .InputMessage = ""
        .ErrorMessage = ""
        .ShowInput = True
        .ShowError = True
    End With
End Sub
Ich möchte aber nur die Werte angezeigt bekommen, wo kein G in der Spalte dahinter steht.

Wie mach ich das?
Krieg es aber noch nichtmal händisch hin.
Sind natürlich nicht nur die 10 Werte sondern in echt mehr, sodaß eine Schleife ungünstig wäre.

Mit arrays kenn ich mich zu wenig aus.

Danke vorab und Grüße von Uwe

  

Betrifft: AW: Auswahlgültigkeit per vba von: Oberschlumpf
Geschrieben am: 27.05.2017 08:03:43

Hi Uwe

anstelle der Datenansicht, die du uns zeigst, wäre per Upload eine Excel-Bsp-Datei besser...inklu der Bsp-Daten.

Ciao erst mal
Thorsten


  

Betrifft: AW: Auswahlgültigkeit per vba von: Hajo_Zi
Geschrieben am: 27.05.2017 09:26:00

erstelle eine Hilfsliste.

Tabelle3

 EFGH
1Möglich gesperrt   
2AA01 AA01 
3AA02 AA02 
4AA03GAA04 
5AA04 AA06 
6AA05GAA07 
7AA06 AA08 
8AA07 AA09 
9AA08 AA10 
10AA09   
11AA10   
12HTTP://WWW.excelformeln.de/formeln.html?welcher=28   

verwendete Formeln
Zelle Formel Bereich N/A
G2:G11{=WENNFEHLER(INDEX(E:E;KKLEINSTE(WENN($F$2:$F$11<>"G";ZEILE($2:$11));ZEILE()-1));"")}$G$2 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.10 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Auswahlgültigkeit per vba von: Der Uwe
Geschrieben am: 27.05.2017 13:46:37

Hallo Hajo

Super Idee. Werde ich mal versuchen.

Danke


  

Betrifft: AW: weiter geht es ... von: ... neopa C
Geschrieben am: 29.05.2017 19:26:13

Hallo @all,

... nun offensichtlich hier: https://www.herber.de/forum/archiv/1560to1564/t1560996.htm

Gruß Werner
.. , - ...