Microsoft Excel

Herbers Excel/VBA-Archiv

Prüfung mehrere Werte und farbliche Darstellung


Betrifft: Prüfung mehrere Werte und farbliche Darstellung von: Johann Schauer
Geschrieben am: 29.09.2017 08:20:46

Hallo Excel Gemeinde,
ich bin auf der Suche nach einer Möglichkeit folgender Ausgabeform:

Erklärung: Es sollen in der Spalten A, B(nur die rechten 3 Werte) und C geprüft werden. Stimmen diese Überein, dann soll das ganze farblich in grün markiert werden, ansonsten in rot. Ist dieses mit Excel Boardmitteln überhaupt zu realisieren oder wird hier VBA benötigt (hier bin ich leider nicht ganz so fit) ...
Über Antworten jeglicher Art wäre ich sehr dankbar ...

  

Betrifft: AW: das geht mit bedingter Formatierung ... von: ... neopa C
Geschrieben am: 29.09.2017 08:28:01

Hallo Johann,

.. z.B. mit folgender Formel (ungetestet):

 =SUMME((RECHTS(B$3:B9;3)=RECHTS(B3;3))*(C$3:C9=C3))>1
Bin jetzt gleich offline

Gruß Werner
.. , - ...


  

Betrifft: AW: das geht mit bedingter Formatierung ... von: Johann Schauer
Geschrieben am: 29.09.2017 08:53:04

Also bei mir passiert hier leider rein gar nichts ... und ausserdem soll ja auch in der Überprüfung die Spalte A geprüft werden. Nur wenn OE, IP und die rechten 3 Zeichen in der ID übereinstimmen (sprich doppelt vorhanden sind), soll eine grüne Markierung erfolgen (am besten für die Zelle der ID).... wenn das nicht stimmt, (sprich wenn zwar OE und IP doppelt vorkommen, aber die letzten 3 Zeichen der ID unterschiedlich sind), dann rote Markierung ...


  

Betrifft: AW: dazu nachgetragen ... von: ... neopa C
Geschrieben am: 29.09.2017 17:36:40

Hallo Johann,

... ich hatte ja auch geschrieben: mit bedingte Formatierung. Wie ich jetzt lesen konnte, hast Du damit noch wenig Erfahrung. Mehr dazu sieh mal u.a. hier: http://www.online-excel.de/excel/singsel.php?f=74

Die Überprüfung der Spalte hielt ich nicht für notwendig, weil diese Werte da bereits gleich waren. Wenn das aber nicht der Fall sein kann, dann für "grün":

=SUMME((RECHTS(B$3:B9;3)=RECHTS(B3;3))*(A$3:A9=C3)*(C$3:C9=C3))>1
Gruß Werner
.. , - ...


  

Betrifft: AW: das geht mit bedingter Formatierung ... von: UweD
Geschrieben am: 29.09.2017 09:25:42

Hallo


so???


Tabelle2

 ABCD
1OEIDIPErgebnis
21007100553'10.252.1.253 
310071007553'10.252.1.253 
41007100186'10.252.10.47 
510071007129'10.252.10.47 
620071007129'10.252.10.47 
die bedingte Formatierung Fülleffekte, Symbole, Datenbalken
werden in dieser Tabelle nicht dargestellt

Bedingte Formatierung Haupttabelle 1  
Wird angewendet auf   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füllfarbe   Unterstrichen   Schrift- farbe Muster   Musterfarbe Typ Bereich
$D$2:$D$99901.Bed.: Formel ist =A2=""   Test         2D2: D999
$D$2:$D$99902.Bed.: Formel ist =SUMMENPRODUKT(($A$2:$A$999&"#"&RECHTS($B$2:$B$999;3)&"#"&$C$2:$C$999=A2&"#"&RECHTS(B2;3)&"#"&C2)*(1))>1  5287936         2D2: D999
$D$2:$D$99903.Bed.: Formel ist =SUMMENPRODUKT(($A$2:$A$999&"#"&RECHTS($B$2:$B$999;3)&"#"&$C$2:$C$999=A2&"#"&RECHTS(B2;3)&"#"&C2)*(1))=1  255         2D2: D999
Bedingte Formatierung Haupttabelle 2 oberere/unterer Bereich    
Wird angewendet auf   Nr. Bed.  Format Zelle Anhalten Auswahl   Anzeige   Anzahl   Durchschnitt   Typ   Bereich
$D$2:$D$99901.Bed.   Wahr          2D2:D999
$D$2:$D$99902.Bed.   Falsch          2D2:D999
$D$2:$D$99903.Bed.   Falsch          2D2:D999
Die Bedingungen wurden mit Excel-Version ab 2007 ausgelesen.

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 21.10 einschl. 64 Bit




LG UweD


  

Betrifft: AW: das geht mit bedingter Formatierung ... von: Johann Schauer
Geschrieben am: 29.09.2017 10:00:32

Hi Uwe,
ja, das Ergebnis würde super passen ... aber leider weiss ich nicht genau wie ich die bedingte Formatierung hinbekomme? Was muss ich hier genau auswählen? Sind es dann insgesamt 2 bedingte Formatierungen mit jeweils 3 Formeln?
Wie muss ich hier beginnen? Sorry ... bin nicht so der Excel Spezialist ...




  

Betrifft: AW: das geht mit bedingter Formatierung ... von: Johann Schauer
Geschrieben am: 29.09.2017 10:15:51

Hi Uwe,
ja, das Ergebnis würde super passen ... aber leider weiss ich nicht genau wie ich die bedingte Formatierung hinbekomme? Was muss ich hier genau auswählen? Sind es dann insgesamt 2 bedingte Formatierungen mit jeweils 3 Formeln?
Wie muss ich hier beginnen? Sorry ... bin nicht so der Excel Spezialist ...




  

Betrifft: AW: das geht mit bedingter Formatierung ... von: Luschi
Geschrieben am: 29.09.2017 10:22:03

Hallo Johann,

daß Du Bilder erzeugen und hier hochladen kannst, hast Du ja bewiesen, aber wie wäre es zur Abwecchgslunng mal mit einer richtigen
Excel-Demo-Datei - und die Ausrede, es sind Firmendaten, gilt nicht, man kann sie auch anonymisieren.

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: das geht mit bedingter Formatierung ... von: Johann Schauer
Geschrieben am: 29.09.2017 10:46:35

Bitte sehr ... hier die Beispieltabelle ...
https://www.herber.de/bbs/user/116621.xlsx


  

Betrifft: AW: das geht mit bedingter Formatierung ... von: UweD
Geschrieben am: 29.09.2017 11:57:52

Hallo


das ist doch schon die richtige Ecke...

Bei "Werte formatieren für diese Formel" kopiert die die Formeln rein.

1)

=SUMMENPRODUKT(($A$2:$A$999&"#"&RECHTS($B$2:$B$999;3)&"#"&$C$2:$C$999=A2&"#"&RECHTS(B2;3)&"#"&C2)*(1) )=1


dann bei "Formatieren" die Füllung auf rot



"neue Regel" analog

2)
=SUMMENPRODUKT(($A$2:$A$999&"#"&RECHTS($B$2:$B$999;3)&"#"&$C$2:$C$999=A2&"#"&RECHTS(B2;3)&"#"&C2)*(1) )>1 
formatieren auf grün




3)
=A2=""
keine Weitere Formatierung



In dieser Ansicht dann noch den "Wird angewendet auf" eintragen/ändern

und den Haken "Anhalten" bei der oberen Bedingung setzen




LG UweD


  

Betrifft: AW: das geht mit bedingter Formatierung ... von: Johann Schauer
Geschrieben am: 29.09.2017 13:33:18

Alles klar .... funktioniert bestens .... Vielen Dank !!!


  

Betrifft: AW: in bed. Formatier. reicht auch nur SUMME() ... von: ... neopa C
Geschrieben am: 29.09.2017 17:40:52

Hallo Uwe,

... da hier Matrixformeln als solche ausgewertet werden.

Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Prüfung mehrere Werte und farbliche Darstellung"