Microsoft Excel

Herbers Excel/VBA-Archiv

Excelformel ANZAHL


Betrifft: Excelformel ANZAHL von: nil
Geschrieben am: 05.12.2017 09:05:51

Hallo liebes Forum,

ich habe eine Zeile in der sich von A1:F1 die Zahl 1 befindet, welches für den Monat Januar steht.

Ich möchte die ANZAHLder Zahlen zählen die sich unter der eins befinden. Das wäre von Zeile A3:F3 = 6 und A5:F5 ebenfalls 6 insgesamt 12. Die Zahlen in den Zeilen G3:H3 und H5:H5 betrachte ich erst gar nicht weil sie sich nicht unter dem Januar der 1) befinden.

Meine Formel bisher


=WENN(A1:H1=1;ANZAHL(A3:H3);"")  
zählt trotz der Bedingung A1:H1 genau 8 Stück, aber das wäre falsch weil die G und H nicht unter der 1 liegen.

  

Betrifft: AW: Excelformel ANZAHL von: SF
Geschrieben am: 05.12.2017 09:08:37

Hola,

mit Wenn kannst du keine Bereiche vergleichen, nur einzelne Zellen.
Für mich klingt das nach Zählenwenns().

Gruß,
steve1da


  

Betrifft: AW: Excelformel ANZAHL von: nil
Geschrieben am: 05.12.2017 09:09:27

Hi Steve1da,

ich habe es mit ZÄHLENWENNS auch schon probiert, aber konnte die Formel nicht richtig aufstellen, damit es funktioniert..


  

Betrifft: AW: Excelformel ANZAHL von: SF
Geschrieben am: 05.12.2017 09:11:17

Hola,

=ZÄHLENWENNS(A1:F1;1;A3:F3;"<>")

Gruß,
steve1da


  

Betrifft: AW: Excelformel ANZAHL von: nil
Geschrieben am: 05.12.2017 09:20:54

Das funktioniert perfekt, aber ich muss ja quasi prüfen ob sich oberhalb der G3:H3 auch eine _ eins befindet, wenn ich jetzt deine Formel in

=ZÄHLENWENNS(A1:F1;1;G3:H3;"<>") 
ändere funktioniert es wieder nicht. Die 1 steht eigentlich für den Januar und der ändert sich ja mal jedes Jahr. Deshalb muss den ganzen Bereich betrachten der eventuell unter die 1 fallen könnte :D


  

Betrifft: AW: Excelformel ANZAHL von: SF
Geschrieben am: 05.12.2017 09:23:00

Hola,

du musst doch nur den Bereich ändern.

=ZÄHLENWENNS(A1:H1;1;A3:H3;"<>")
Gruß,
steve1da


  

Betrifft: AW: Excelformel ANZAHL von: nil
Geschrieben am: 05.12.2017 09:38:21

Hatte einen Schreibfehler drin! DANKE! es funktioniert !!!


  

Betrifft: AW: Excelformel ANZAHL von: Werner
Geschrieben am: 05.12.2017 09:20:49

Hallo,

meinst du so?
=SUMMENPRODUKT((A1:F1=1)*(ISTZAHL(A3:F3))+(ISTZAHL(A5:F5)))

Gruß Werner


  

Betrifft: AW: Excelformel ANZAHL von: nil
Geschrieben am: 05.12.2017 09:38:50

Danke´für deine Antwort und Mühe !


  

Betrifft: Bedeutet? so nicht richtig? o.w.T. von: Werner
Geschrieben am: 05.12.2017 09:46:43




Beiträge aus den Excel-Beispielen zum Thema "Excelformel ANZAHL"