Microsoft Excel

Herbers Excel/VBA-Archiv

Rang


Betrifft: Rang von: Andre
Geschrieben am: 26.01.2018 10:21:32

Hallo Forummitglieder,

ich habe eine Tabelle mit 3 Ergebnissen. Diese will ich mit dem Rang auswerten lassen und mir so anzeigen lassen wer 1,2 und 3 ist. Nun meine Frage: Wie kann ich es machen das wenn einer sich nicht beteiligt und der Wert 0€ beträgt das dieser an die letzte Position gestellt wird?

Habe es schon mit der Wenn Funktion versucht bekomme es aber nicht hin.

Danke für eure Vorschläge

  

Betrifft: AW: Rang von: SF
Geschrieben am: 26.01.2018 10:23:08

Hola,

genau das macht Rang() doch.

Gruß,
steve1da


  

Betrifft: AW: Rang von: Andre
Geschrieben am: 26.01.2018 10:26:09

Hallo steve1da

leider geht das nicht. Das 1. Ergebnis ist als Bsp. 245,30, das 2. = 0 (keine Beteiligung) und da macht der Rang die Belegung so: Ergebnis 1 = 2, Ergebnis 2 = 1


  

Betrifft: AW: Rang von: SF
Geschrieben am: 26.01.2018 10:33:45

Hola,

da du deine Formel geheim hälst kann ich nur raten: du hast die Reihenfolge bei Rang() auf 1 stehen.

Gruß,
steve1da


  

Betrifft: AW: Rang von: Andre
Geschrieben am: 26.01.2018 10:37:12

Hallo,

hier ist mein Code

RANG(C11;$C$11:$E$11;1)


  

Betrifft: AW: Rang von: SF
Geschrieben am: 26.01.2018 10:39:32

Hola,

mein Satz geht nach dem Doppelpunkt noch weiter.

Gruß,
steve1da


  

Betrifft: AW: Rang von: Andre
Geschrieben am: 26.01.2018 10:42:02

Hallo steve1da,

ich habe es jetzt mal probeweise geändert und den wert von 1 auf 0 gesetzt. Nun zeigt er mir den teuersten mit 1 an und den günstigsten mit 2. der sich nicht beteiligt hat wird 3 das wäre schon mal ok.

danke für deine Hilfe


  

Betrifft: AW: Rang von: SF
Geschrieben am: 26.01.2018 10:43:47

Hola,

ein konkretes Zahlenbeispiel könnte helfen.

Gruß,
steve1da


  

Betrifft: AW: Rang von: Andre
Geschrieben am: 26.01.2018 10:49:20

Hallo,

Ergebnis 1 = 245,30
Ergebnis 2 = 0,00
Ergebnis 3 = 240,23

Nun soll mit Rang der günstigste gesucht werden unter Berücksichtigung ob ein Gebot abgegeben wurde.

Danke


  

Betrifft: AW: Rang von: SF
Geschrieben am: 26.01.2018 10:52:22

Hola,

oben hieß es noch: und der Wert 0€ beträgt das dieser an die letzte Position gestellt wird?
Das wäre bei dann Rang 3 - jetzt soll er aber nicht mit einem Rang versehen werden? Dann nimm Sepps letzten Vorschlag.

Gruß,
steve1da


  

Betrifft: AW: Rang von: Andre
Geschrieben am: 26.01.2018 11:04:25

Hallo,

leider funktioniert das vom Sepp nicht er zeigt mir immer andere Werte an.

z. B. so sieht in etwa meine Tabelle aus

Anbieter 1 683,39
Anbieter 2 - €
Anbieter 3 673,54

nun sollen die 3 Ergebnisse verglichen werden, und mit Rang ausgewertet nach dem Günstigsten bis zum teuersten mit denen die kein Gebot abgegeben haben.


  

Betrifft: AW: Rang von: SF
Geschrieben am: 26.01.2018 11:06:16

Hola,

sorry, aber ich habe keine Lust mehr zu erraten, was du jetzt gerne als Ergebnis hättest oder was "immer andere Werte" genau sind. In deinen Beispielen gibt es nirgends ein konkretes Wunschergebnis.
Viel Erfolg noch.

Gruß,
steve1da


  

Betrifft: AW: Rang von: Andre
Geschrieben am: 26.01.2018 11:19:32

Ich habe mich vielleicht nicht richtig erklärt.

Als Rang soll mir 1,2 oder 3 usw. angezeigt werden sortiert nach dem günstigstem Angebot. Wenn einer kein Angebot abgeben hat soll er an letzter Stelle stehen also 3 oder 4 je nachdem wie viele Anbieter sich beteiligt haben.


  

Betrifft: AW: Rang von: Sepp
Geschrieben am: 26.01.2018 10:33:28

Hallo Andre,

so?

Tabelle2

 AB
1ErgebnisRang
2254,232
30 
4278,391

Formeln der Tabelle
ZelleFormel
B2=WENN(A2=0;"";SUMMENPRODUKT((A2:A4>A2)*(A2:A4>0))+1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



Gruß Sepp



  

Betrifft: AW: Rang von: Andre
Geschrieben am: 26.01.2018 10:38:26

Hallo Sepp,

im Grunde schon, aber es soll der Günstigste ermittelt werden.


  

Betrifft: AW: Rang von: Sepp
Geschrieben am: 26.01.2018 10:47:17

Hallo Andre,

Tabelle2

 AB
1ErgebnisRang
2254,231
30 
4278,392

Formeln der Tabelle
ZelleFormel
B2=WENN(A2=0;"";SUMMENPRODUKT(($A$2:$A$4<A2)*($A$2:$A$4>0))+1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



Gruß Sepp



  

Betrifft: AW: Rang von: Rudi Maintaire
Geschrieben am: 26.01.2018 12:35:28

Hallo,
wenn du die ohne Angebot einfach leer lässt oder Text in die Zelle schreibst (z.B. "-")
=WENNFEHLER(RANG(A1;$A$1:$A$3;1);"")

Gruß
Rudi


  

Betrifft: Alles Kokolores, ... von: Luc:-?
Geschrieben am: 26.01.2018 16:46:32

…Leute;
RANG ist so konzipiert, dass Leerzellen einfach ausgelassen wdn! Warum muss dann unbedingt etwas bei Nichtbietern eingetragen wdn? Das allein verursacht das Problem.
Ansonsten würde für einen gesetzten Strich (nicht Format für 0!) schon diese Fml reichen:
=WENN(B1="-";"-";RANG(B1;B$1:B$3;1))
🙈 🙉 🙊 🐵 Gruß, Luc :-?

„Die Intelligenzmenge ist auf diesem Planeten eine Konstante, die Bevölkerung nimmt aber zu!“ Auch deshalb informieren mit …


  

Betrifft: is mein Reden. owT von: Rudi Maintaire
Geschrieben am: 27.01.2018 21:36:56




  

Betrifft: Ich weiß! ;-) owT von: Luc:-?
Geschrieben am: 27.01.2018 23:15:55

:-?