Microsoft Excel

Herbers Excel/VBA-Archiv

Glätten aus 3 Zellen

Betrifft: Glätten aus 3 Zellen von: Erik
Geschrieben am: 07.02.2020 14:29:57

Hallo zusammen,


ich habe folgende Formel in meiner Zelle C7


=WENN(ANZAHL2(T7:V7)=3;T7 &" " &V7;GLÄTTEN(T7&" "&U7&" "&V7))


Excel sucht sich auf den Spalten T - V die Telefonnummern und setzt 2 davon in meine Zelle.

Dies funktioniert soweit aber leider nur bedingt.

In den Spalten T U und V ist ein SVerweis


=WENNFEHLER(WENN(SVERWEIS(D7; '\\Aldc01\d\Daten\Lager\Kundenteile\Werkstatt\[Kundenstamm.xlsm]Kennzeichen - Kd Nummer'!$A:$U;11; FALSCH)=0;"";SVERWEIS(D7; '\\Aldc01\d\Daten\Lager\Kundenteile\Werkstatt\[Kundenstamm.xlsm]Kennzeichen - Kd Nummer'!$A:$U;11; FALSCH));"")


wenn jetzt in der Spalte T und U ein Eintrag vorhanden ist V jedoch leer ist nimmt Excel in meiner Zelle C7 nur den Eintrag aus T (weil die Spalte V nicht als leer gewertet wird).

Lösche ich die Formel aus V funktioniert die glätten Formel.


Kann man das irgendwie abändern?


Vielen lieben Dank


Erik

Betrifft: '\\Aldc01\d\Daten\Lager\Kundenteile\Werkstatt\[Ku
von: WF
Geschrieben am: 07.02.2020 16:28:33

Glaubst Du im Ernst, das baut jemand nach ?

WF

Betrifft: AW: Glätten aus 3 Zellen
von: Erik
Geschrieben am: 07.02.2020 16:44:07

Hier die Datei zum besseren Verständnis.

https://www.herber.de/bbs/user/135056.xlsx

Betrifft: AW: Glätten aus 3 Zellen
von: Erik
Geschrieben am: 07.02.2020 16:48:07

in diesem Fall funktioniert Name B nicht.
Es wird nur die Telefonnummer 4444 ausgegeben
Telefonnummer 5555 fehlt.

Löscht man Zelle V2

werden (wie gewünscht) beide Telefonnummern angezeigt

Betrifft: =GLÄTTEN(T2&" "&U2&" "&V2) langt doch
von: WF
Geschrieben am: 07.02.2020 17:13:33

.

Betrifft: bzw.bei 3 Treffern nur 1 und 3 anzeigen
von: WF
Geschrieben am: 07.02.2020 17:29:07

Nimm ANZAHL - nicht ANZAHL2

WF

Betrifft: AW: bzw.bei 3 Treffern nur 1 und 3 anzeigen
von: Erik
Geschrieben am: 08.02.2020 08:09:41

Hallo WF,

das funktioniert leider nicht es dürfen max 2 von drei belegten Zellen angezeigt werden.

Gruß
Erik

Betrifft: lass Deine Formel unverändert
von: WF
Geschrieben am: 08.02.2020 09:02:27

nur mit ANZAHL (statt ANZAHL2)

Betrifft: kT
von: Erik
Geschrieben am: 08.02.2020 09:51:28

kT

Betrifft: AW: und was genau meinst Du damit? ...
von: neopa C
Geschrieben am: 08.02.2020 10:29:14

Hallo Erik,

... und meist sind (komplette) Telefonnummerangaben keine Zahlen. In so einem Fall nutzt Dir ANZAHL() nichts, dann nimm anstelle der Prüfung von ANZAHL2(), welche auch ein ="" Ergebniswert als einen Wert ermittelt, z.B. folgendes: =WENN(ZÄHLENWENN(T2:V2;"?*")=3;...

Gruß Werner
.. , - ...

Betrifft: AW: und was genau meinst Du damit? ...
von: Erik
Geschrieben am: 08.02.2020 12:04:22

Hallo Werner,

vielen Dank für Deinen Tipp!
mit =WENN(ZÄHLENWENN(T2:V2;">0")>2;T2&" "&V2;T2&" "&U2&V2)

konnte ich es umsetzten.

Gruß
Erik

Betrifft: AW: wenn dem so ist, ...
von: neopa C
Geschrieben am: 08.02.2020 19:21:27

Hallo Erik,

... dann sind Deine Telefonnummern offensichtlich doch Zahlen. Dann hätte Dir auch der Rat von WF bereits helfen müssen, in Deiner Formel die Funktion ANZAHL() anstelle ANZAHL2() zu nutzen.

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Glätten aus 3 Zellen"