Microsoft Excel

Herbers Excel/VBA-Archiv

Preisspiegel Selektion

Betrifft: Preisspiegel Selektion von: Tobias Hecht
Geschrieben am: 05.10.2020 08:27:32

Hallo liebe Excel Freunde,

es geht um folgendes Problem.

ich habe einen Preisspiegel für Schüttmaterialien. Diese sollen in Gruppen eingeteilt werden. Alsp sprich Sand, Frostschutz usw ...

https://www.herber.de/bbs/user/140652.xlsx


Jetzt soll über die bedingte Formatierung in der Spalte "Sattel" immer der günstigste Preis für die jeweilige Gruppe selektiert werden.

Soweit so gut, dass funktioniert auch.

Wenn aber jetzt beim 2 Lieferanten z.B. der Sand in der Spalte "Sattel" mit 5,00 EUR am günstigsten ist, er mir sämtliche Zellen selektiert, in deinen die Zahl 5 vorkommt. (Auch wenn er in der jeweiligen Gruppe nicht der günstigste ist). Egal ob in der Spalte Sattel oder ab Werk. er such den Wert 5,00 und markiert sämtliche Zellen.

z.B. in der Gruppe Schotter markiert er in Zeile 42 die 7,20 in der Spalte K "Sattel" aber auch die Zelle G42. (obwohl die Spalte nicht Sattel heißt).

Warum?

2. tes Problem wenn ich jetzt 3 Lieferanten habe und den 2. Lieferanten ausblende, dann wird er trotzdem berücksichtigt. wie könnte man das umgehen?!

ich hoffe ihr könnt mir folgen.

Mit bestem Dank bereits im Voraus für Ihre Hilfe und Lösungen.

Betrifft: AW: da Du schon mit einer Hilfspalte arbeitest ...
von: neopa C
Geschrieben am: 05.10.2020 10:38:27

Hallo Tobias,

... da kannst Du z.B. in AE eine weitere anlegen.

für 1.)
In AE8 dann z.B.:
=WENNFEHLER(WENN((AD8=AD7)+(AD8="");"";AGGREGAT(15;6;$F$8:$Y$46/($AD$8:$AD$46=$AD8)/($F$8:$AY$46<>"");1));"")

und nach unten kopieren.

Dann als bedingte Formatierungsformel folgende:

=(F$7="Sattel")*(F8=SVERWEIS($AD8;$AD:$AE;2;0))*(F8<>"")

Für 2.)

hier würde ich eine Hilfszeile anlegen und in dieser die Spalten die nicht ausgeblendet werden sollen mit einer 1 belegen und die restlichen Zellen leer lassen bzw. löschen oder eine 0 einschreiben und dafür dann die Formel in AE8 mit Bezug auf diesen Hilfszellenbereich entsprechend erweitern.

Gruß Werner
.. , - ...

Betrifft: AW: da Du schon mit einer Hilfspalte arbeitest ...
von: Tobias Hecht
Geschrieben am: 05.10.2020 12:11:02

Hallo Werner,
danke für deine Hilfe und für deinen tollen Lösungsvorschlag. in der Beispiel Datei funktioniert es super.
Diesen letzten Passus in deiner Formel verstehe ich nicht . Warum AY. Diese Spalte gehört doch nicht zu den auzuwertenden Spalten ...

wollte es gerade auf eine andere Datei anwenden.
https://www.herber.de/bbs/user/140660.xlsx

Aber in der Hilfsspalte findet er jetzt immer den kleinsten Wert egal welche Spalte. und mit der bedingten Formatierung markiert er den kleinsten Wert, vorausgesetzt er ist in der Spalte "Sattel".

Außerdem hätte ich noch eine Frage zu meiner bereits bestehenden Formatierung. Obwohl ich nur jeweils eine Formel anlege für die Selektion "ab Werk", "Sattel" finde ich eine Vielzahl von Formeln wenn ich mir die Formeln für dieses Arbeitsblatt anzeigen lasse. (warum macht er soviel Unterformeln).

Betrifft: AW: hierzu ...
von: neopa C
Geschrieben am: 05.10.2020 12:32:45

Hallo Tobias,

... mein AY in der Formel war einfach ein Schreibfehler. Die Formel sollte natürlich so: ... /($F$8:$Y$46<>"");1));"") lauten.

Wenn nur die Werte von "Sattel" betrachten werden sollen/müssen, muss die Hilfsspaltenformel dann erweitert werden zu:
=WENNFEHLER(WENN((AD8=AD7)+(AD8="");"";AGGREGAT(15;6;$F$8:$Y$46/($AD$8:$AD$46=$AD8)/($F$8:$Y$46>0) /($F$7:$Y$7="Sattel");1));"")

weil anderenfalls ein kleinerer Wert in einer Spalte außerhalb von "Sattel" stehen könnte und dort dann keine Markierung durch HG-Farbe im Bereich erfolgen kann.

Deine neue Datei hab ich mir noch nicht weiter angeschaut aber vielleicht hilft Dir ja das vorgenannte schon weiter.

Gruß Werner
.. , - ...