Microsoft Excel

Herbers Excel/VBA-Archiv

Formel erweitern

Betrifft: Formel erweitern von: Patrik Achermann
Geschrieben am: 24.10.2020 11:17:32

Hallo Miteinander

Ich habe eine Tabelle mit diversen Formeln und Berechnungen.
Ich möchte diese Tabelle umgestalten und erweitern weiss aber nicht genau wie.
Deshalb brauche ich Eure Hilfe.

In der Zelle F8 steht folgende Formel:
=WENNFEHLER(WENN(I8="KartonBox 1";ABRUNDEN(B$2/B8;0); ABRUNDEN(B$3/B8;0));"")

Das heisst wenn in der Zelle I8 KartonBox 1 steht soll die Höhe von Zelle B2 durch die Stärke von Zelle B8 geteilt und abgerundet werden.
Wenn in der Zelle I8 nichts steht soll die Höhe von Zelle B3 durch die Stärke von Zelle B8 geteilt und abgerundet werden.

Soweit so gut das passt alles.

Nun möchte ich diese Formel in der Zelle F8 erweitern mit: wenn in der Zelle A4 LOSE steht soll die Höhe von Zelle B4 durch die Stärke von Zelle B8 geteilt und abgerundet werden.

Ich hoffe habe es verständlich Beschrieben.
Sonst zur Hilfe die Datei:

https://www.herber.de/bbs/user/141053.xlsx

Gruss, Patrik

Betrifft: AW: Formel erweitern
von: SF
Geschrieben am: 24.10.2020 13:05:10

Hola,

gleiches Prinzip wie bei deiner letzten Frage....

Gruß,
steve1da

Betrifft: AW: Formel erweitern
von: Patrik Achermann
Geschrieben am: 24.10.2020 14:27:08

Hallo

ok super Danke

Gruss, Patrik

Betrifft: AW: Formel erweitern
von: onur
Geschrieben am: 24.10.2020 13:14:38

=WENNFEHLER(SVERWEIS($I8;$A$1:$B$4;2;FALSCH)/$B8;"")


Betrifft: AW: Formel erweitern
von: Patrik Achermann
Geschrieben am: 24.10.2020 14:38:49

Hallo Onur

Vielen Dank für die Antwort.
Die Formel passt nicht ganz.
Denn es sollte noch abgerundet werden.
Wie sieht die Formel denn aus?

Gruss, Patrik

Betrifft: AW: Formel erweitern
von: Christian
Geschrieben am: 24.10.2020 15:02:05

Hallo Patrik,

ungetestet:

=WENNFEHLER(ABRUNDEN(SVERWEIS($I8;$A$1:$B$4;2;FALSCH)/$B8;?);"")

Wobei du das Fragezeichen noch durch die Anzahl der Stellen auf die du runden möchtest ersetzen musst.

Gruß
Christian

Betrifft: AW: Formel erweitern
von: Patrik Achermann
Geschrieben am: 24.10.2020 15:07:06

Hallo Christian

Vielen Dank für die Antwort.
Funktioniert einwandfrei.
Du hast mir echt geholfen, Danke.

Gruss, Patrik

Betrifft: AW: Formel erweitern
von: Christian
Geschrieben am: 24.10.2020 15:29:47

gerne doch.

Christian

Beiträge aus dem Excel-Forum zum Thema "Formel erweitern"