Microsoft Excel

Herbers Excel/VBA-Archiv

Teilergebnisse/Gruppierung

Betrifft: Teilergebnisse/Gruppierung
von: Josef Gareis
Geschrieben am: 11.04.2003 - 20:05:03

Hallo im Forum,

hier meine ungelöste Frage zu Teilergebnissen:

Kennt jemand eine Möglichkeit, in einer Excel-Liste Teilergebnisse nur für solche Gruppen, die aus mehreren Zeilen bestehen, einfügen zu lassen?
Standardmäßig erzeugt Excel auch für einzelne Zeilen eine Zeile mit dem Teilergebnis.
Genial wäre eine Lösung ohne Programmieraufwand...

Danke im Voraus,
Josef

  

Re: Teilergebnisse/Gruppierung
von: gordon
Geschrieben am: 12.04.2003 - 17:03:34

Hallo Josef,
was hälst Du von:

=WENN(ZÄHLENWENN($A$1:$A$10;A1)>1;TEILERGEBNIS(1;$A$1:$A$10);"")

(in A1 bis A10 stehen die Kennzeichen für den Gruppenwechsel, Formel in Spalte B)

Gruß
gordon

  

Re: Teilergebnisse/Gruppierung
von: Josef G.
Geschrieben am: 13.04.2003 - 16:14:00

Hallo Gordon,

danke für Deine Formel, sie löst aber leider nicht mein Problem, das ich vielleicht etwas genauer beschreiben sollte:

Mit Teilergenissen meine ich die über Menü "Extras/Teilergebnisse..." eingebaute Möglichkeit, Zwischenergebnisse incl. Gliederung für Gruppen von Zeilen automatisch erstellen zu lassen. Dies geschieht aber auch für einzelne Zeilen, für die es ja nichts zu summieren (oder zu zählen etc.) gibt, was die Auswertung eher unübersichtlich macht.

Das ist aber vermutlich nicht kontrollierbar, oder gibt es doch einen Kniff?


Grüsse,
Josef

  

Re: Teilergebnisse/Gruppierung
von: gordon
Geschrieben am: 13.04.2003 - 21:07:14

Hallo Josef,

Extras/Teilergebnisse ist meiner Kenntnis nach nicht weiter zu beeinflussen, probier halt die Formel mal aus, Du könntest z.B. über bedingte Formatierung einer Zeile, die in der Spalte mit den Formeleinträgen einen Wert <> "" hat, diese Zeile fett formatieren und hättest optisch ein ähnliches Ergebnis.

Gruß
gordon

  

Re: Teilergebnisse/Gruppierung
von: gordon
Geschrieben am: 13.04.2003 - 21:07:15

Hallo Josef,

Extras/Teilergebnisse ist meiner Kenntnis nach nicht weiter zu beeinflussen, probier halt die Formel mal aus, Du könntest z.B. über bedingte Formatierung einer Zeile, die in der Spalte mit den Formeleinträgen einen Wert <> "" hat, diese Zeile fett formatieren und hättest optisch ein ähnliches Ergebnis.

Gruß
gordon

  

Re: Teilergebnisse/Gruppierung
von: gordon
Geschrieben am: 13.04.2003 - 21:07:15

Hallo Josef,

Extras/Teilergebnisse ist meiner Kenntnis nach nicht weiter zu beeinflussen, probier halt die Formel mal aus, Du könntest z.B. über bedingte Formatierung einer Zeile, die in der Spalte mit den Formeleinträgen einen Wert <> "" hat, diese Zeile fett formatieren und hättest optisch ein ähnliches Ergebnis.

Gruß
gordon