Microsoft Excel

Herbers Excel/VBA-Archiv

Spalten vergleichen

Betrifft: Spalten vergleichen
von: Anselmo
Geschrieben am: 16.04.2003 - 14:19:04

Hallo, wir haben folgendes Problem und zwar
brauchen wir eine Formel, die verschiedene Spalteneinträge erkennt und hochzählt (um Varianten zu erkennen)
Bsp.

12 14 14 15 13 als Ergebnis müsste jetzt 4 in der Ergebnisspalte anzeigen.

14 14 14 14 14 als Ergebnis müsste jetzt 1 erscheinen !

Gibt es da eine "Vergleichen-Funktion ?

Danke schon mal im voraus

Gruss Markus

  

Re: Spalten vergleichen
von: ChristianG
Geschrieben am: 16.04.2003 - 15:21:11

Hi Markus,

=SUM((FREQUENCY(A1:A14,A1:A14)>0)*1)
Zählt unterschiedliche Einträge im Bereich A1 bis A14. (englische Excel-Version)

Ich kann es im Moment leider nicht in deutsch testen, aber es sollte dann folgendermaßen aussehen:

=SUMME((HÄUFIGKEIT(A1:A14;A1:A14)>0)*1)

Gruß
Christian

 

Beiträge aus den Excel-Beispielen zum Thema "Spalten vergleichen"