Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
264to268
264to268
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

doppelte werte in spalte mit zugehörgigen Werten..

doppelte werte in spalte mit zugehörgigen Werten..
12.06.2003 12:27:48
sabine
...aus der Zeile exportieren, oder an andere Stelle kopieren.

Hi an Alle,

vielleicht könnt ihr mir ja helfen, hab mir schon unzählige sachen zu dubletten durchgelesen, war leider nie das richtige dabei. also: ich habe eine Tabelle mit 12 Spalten und X-hundert Zeilen. In der ersten Spalte links befindet sich die Artikelnummer. Diese ist nun (manchmal) mehrmals vorhanden, allerdings mit unterschiedlichen Beschreibungen des Arikels in der zugeordneten Zeile. (ich brauche diese Beschreibungen aber, da es sich hier auch um unterschiedliche Preis für verschiedene grössen handelt mit der gleichen Artikelnummer).Toll wäre wenn ich jetzt an die Artikelnummern ein suffix (z.B. {artikelnummer}_c1, c2 ... _cx)anhängen könnte. und mir das makro dannach die artikelnummern ausgibt(z.B. an eine andere Stelle oder gleich exportiert), die es verändert hat. mir kommt es im wesentlichen darauf an, dass die artikelnummer hierdurch einmalig werden.

für ein paar ideen, wäre ich sehr sehr dankbar.

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: doppelte werte in spalte mit zugehörgigen Werten..
12.06.2003 12:41:39
Harald Kapp

Re: doppelte werte in spalte mit zugehörgigen Werten..
12.06.2003 12:49:21
Andreas Schindler

Hallo Sabine

Angenommen, die Artikelnummern stehen in Spalte A, die Bezeichnungen in Spalte B.
Dann sortierst Du erstmal Spalte B und Spalte A
D.h. die Artikel stehen wie folgt da:

Artikelnr. Beschreibung
1 ______________A
1______________B
1______________C
2______________A
2______________B

etc.
Dann schreibst Du in Zelle c2:
=WENN(A1=A2;WENN(B1=B2;C1;C1+1);1)
und in Zelle d2:
=A2&"C_"&C2

die beiden kopierst Du dann bis zum Ende Deiner Liste.
Dann die Spalte D markieren.
Bearbeiten kopieren
Bearbeiten inhalte einfügen - werte

und schon hast Du deine neuen eindeutigen Artikelnummern.

GRuß
Andreas




Anzeige
Re: doppelte werte in spalte mit zugehörgigen Werten..
12.06.2003 12:49:38
xxx

Hallo,
wenn es dir nur auf eindeutige Nummern ankommt, kannst du es so machen:
Nach Artikelnummer sortieren.
Neben A 2 neue Spalten einfügen.
in B2: =WENN(A2=A1;B1+1;1)
in C2: =A2&"_C"&B2
die Formeln nach unten kopieren.
Dann hast du in Spalte C lauter einmalige Nummern. Wenn du willst, kannst du die ja über Kopieren-Inhalte einfügen-Werte fixieren und die Spalten A und B löschen.

Gruss aus'm Pott
Udo


Re: doppelte werte in spalte mit zugehörgigen Werten..
12.06.2003 13:28:12
ingo

hallo Sabine,
folgende Formel liefert Dir mE die neue Artikelnummer:

=WENN(ZÄHLENWENN(A:A;A1)>1;A1&"_c"&ZÄHLENWENN($A$1:$A1;A1);A1)
eintragen in neue Spalte b1 und nach unten ziehen

wenn in a:a die Artikelnummer nur einmal vorkommt, wird die originalnummer genommen, sonst wird "_cx" angehängt mit x =1..n

Gruß ingo

Anzeige

388 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige