Microsoft Excel

Herbers Excel/VBA-Archiv

Datum errechnen

    Betrifft: Datum errechnen von: sas
    Geschrieben am: 26.08.2003 13:08:28

    Hallo,
    ich habe folgendes Problem...

    ich möchte ausgehend von einem bestimmten Datum z.B 01.05.2003 eine Frist von 30 Tagen ausrechnen. Das Ergebnisdatum darf weder ein Sa noch ein So oder ein von mir festgelegter Feiertag sein.

    In oberem Beispiel ist das Ergebnis Samstag 12.06.03 wäre der darauffolgende Montag ein von mir definierter Feiertag, dann sollte Excel mir den Di 13.06.03
    als Ergebnis rausgeben.Ist das über ein oder zwei Funktionen machbar ?

    Vielen Dank schon mal :-)

      


    Betrifft: AW: Datum errechnen von: Galenzo
    Geschrieben am: 26.08.2003 13:26:41

    Mein Vorschlag - wenigstens für den ersten Teil der Aufgabe:
    =WENN(WOCHENTAG(A1+30)=1;A1+31;WENN(WOCHENTAG(A1+30)=7;A1+32;A1+30))

    Also der Wochentag des "Datums+30Tage" wird geprüft, wenn's ein Samstag st, dann ist das Ergebnis "Datum+32", wenn's ein Sonntag wäre, dann ist das Ergebnis "Datum+31", sonst ganz normal "Datum+30". Also 2 verschachtelte WENN-Funktionen.
    Für deine Feiertags-Überprüfung müsstest du eben noch eine weitere WENN-Funktion einschachteln.


      


    Betrifft: AW: Datum errechnen von: sergiesam
    Geschrieben am: 26.08.2003 13:48:46

    Hi,

    das ist garnicht leicht. Die Wochenenden sind kein Problem:
    =A1+30+2*(WOCHENTAG(A1+30;2)=6)+(WOCHENTAG(A1+30;2)=7)

    Für die Feiertage müsste man noch ein paar Mal durchlaufen. Es könnte ja der (unwahrscheinliche, aber doch mögliche) Fall sein, dass zuerst ein SA getroffen wird, dadurch muss der MO gefunden werden, >> Feiertag also Dienstag, >> wieder Feiertag (Weihnachten z.B.) >> Mittwoch,...

    Meiner Meinung nach müsste man das in einer VB-Funktion lösen, in der man das Zieldatum immer wieder in deine Feiertagsliste reinschickt und überprüft ob, dieses Datum nun passt.

    Sam


      


    Betrifft: AW: Datum errechnen von: sas
    Geschrieben am: 26.08.2003 14:10:34



    Vielen dank,

    das löst schon einiges an Platzproblemen. Jetzt muss man nur noch die Feiertage definieren als Excelzahl und wenn zutreffend eins dazuzählen. Für Weihnachten ne extra Reihe- aber auch das geht wahrscheinlich weniger umständlich

    Danke und Gruss
    Sas


     

    Beiträge aus den Excel-Beispielen zum Thema " Datum errechnen"