Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
312to316
312to316
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Vektor auf Nullwerte prüfen

Vektor auf Nullwerte prüfen
23.09.2003 16:39:24
Stefan Helling
Hallo,

ich habe eine Matrix, sagen wir A1:G1000.
Nun benötige ich in einem anderen Feld die Anzahl der Zeilen, in denen alle Werte 0 sind. Alle Zählenwenn- und Summewenn-Versuche von mir sind leider fehlgeschlagen.

Über eine Hilfsvariale kann ich auch nicht arbeiten, da Daten nachträglich importiert werden.

Vielen Dank im Voraus,
Gruß Stefan

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
summenprodukt()
23.09.2003 16:47:11
Ingo
Hallo Stefan,

Du kannst folgende Formel nutzen:
=summenprodukt((a1:a1000=0)*(b1:b1000=0)*(C1:c1000=0)*(D1:D1000=0)*(E1:E1000=0)*(F1:F1000=0)*(G1:G1000=0))

bei zuvielen Spalten wirds aber mühsam, ausserdem zählt er auch Leerzellen...

wenn du nicht damit leben kannst melde dich einfach nochmal

Gruß Ingo
Ergänzung
23.09.2003 16:58:19
Ingo
Hallo Stefan, solltest Du mit obiger Formel Probleme haben aus den genannten Gründen liefert dir folgende Matrixformel die anzahl aller Zeilen von 1 - 1000, die in spalte 1-7
nur die Ausprägung 0 haben (leerzellen werden nicht als null interpretiert)

=SUMME((ZÄHLENWENN(BEREICH.VERSCHIEBEN(A1;ZEILE(1:1000)-1;0;1;7);0)=7)*1)
Eingabe abschgließen mit Strg-Shift-Enter

sollest Du mehr spalten benötigen einfach die beiden 7 in eine andere Zahl<=256 ändern

Gruß Ingo

Anzeige
AW: Ergänzung - Super funktioniert klasse!
23.09.2003 17:20:45
Stefan
Hallo Ingo,

vielen Dank.
Das nächste Mal werde ich bevor ich zwei Stunden rumprobiere euch gleich fragen .....

Gruß, Stefan
=HÄUFIGKEIT()
23.09.2003 16:59:43
Karl-Otto Reimann
.
AW: Vektor auf Nullwerte prüfen
23.09.2003 17:13:17
Reinhard
Hallo Stefan,
ich würde wie folgt vorgehen
In eine freie Spalte, z.b.: H folgende Formel in H1:
=wenn(zählenwenn(a1:g1;"0")<7);0;1)
Dann Formel bis bis H1000 runterkopieren.
Dann in beliebige Zelle folgende Formel:
=summe(h1:h1000)
Gruß
Reinhard

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige