Das Archiv des Excel-Forums

Feststellen, ob ein Datum zwischen Datumswerten li

Bild

Betrifft: Feststellen, ob ein Datum zwischen Datumswerten li
von: C. Boeck

Geschrieben am: 29.09.2003 10:28:16

Hallo

ich suche eine Möglichkeit, um bei einem Datum zu testn, ob es in möglichen Schulferien liegt. Es gibt also mehrere Wertepaare zum testen.

Ferien 2004 von bis
Weihnachten 03 22.12.2003 06.01.2004
Winter 02.02.2004 03.02.2004
Ostern 29.03.2004 14.04.2004
Himmelfahrt 21.05.2004 21.05.2004
Pfingsten 01.06.2004 01.06.2004
Sommer 08.07.2004 18.08.2004
Herbst 11.10.2004 23.10.2004
Weihnachten 04 23.12.2004 08.01.2005

Wenn Datum in der Ferien liegt, dann einfärben.

Mit dieser Hilfe versuche ich die bedingte Formatierung zu setzen. Wenn möglich würde ich eine Blattfunktion nutzen. Zur Not auch ein VBA Script.

Bisher habe ich versucht über ODER(UND(Datum>=Start; Datum <=Ende); UND(.....)) leider wird dieser Ausdruck sehr lang und die Einganbe für bedingte Formatierung ist schnell am Ende.

Gibt es hier noch einen Trick mit Matrix Funktionen ?

Vielen Dank für die Hilfe
Carsten
Bild


Betrifft: AW: Feststellen, ob ein Datum zwischen Datumswerten li
von: Panicman
Geschrieben am: 29.09.2003 10:45:44

Hallo Carsten,

versuchs mal hiermit






Formel C1 =SUMMENPRODUKT((B3:B10<=B1)*(C3:C10>=B1))=1

Gruß
Holger


 Bild

Excel-Beispiele zum Thema " Feststellen, ob ein Datum zwischen Datumswerten li"

Feststellen, ob eine Datei in einem Verzeichnis existiert download Feststellen, ob eine bestimmte Zelle markiert ist download
Feststellen, ob eine Schaltfläche mit Shift-Taste gedrückt wurde download Feststellen, welche Datei die ältere ist download
Zwischensumme als Text download Gefilterte Daten ohne Zwischenablage übertragen download
Werte ohne Zwischenspeicher übertragen download Variable in Zwischenablage übernehmen download
Variablen in einer temporären Textdatei zwischenspeichern download Zwischensumme in Fußzeile download
Zwischensummen eintragen download Zwischen zwei UserForms wechseln, wobei sich die 1. Aktualisiert download
Werte aus UserForm-ListBox in die Zwischenablage übernehmen download Startzeit und auf Schaltflächendruck Zwischenzeiten eintragen download
Werte mit Zufallszahl zwischen 1 und 2 multiplizieren download Summen zwischen zwei Zeiträumen ermitteln download
Focus und Selection zwischen zwei TextBoxes wechseln download Eingaben auf Werte zwischen 100 und 200 beschränken download
Leerzeichen zwischen Zeichen- und Zahlenfolge entfernen download Blattwechsel zwischen xlVeryHidden ausgeblendeten Blättern download
Wechseln zwischen Arbeitsblättern anhand mehrerer Schaltflächen download Prüfung, ob die Zwischenablage leer ist download
Auslesen der aktuell in der Zwischenablage vorhandenen Formate download Mit ShortCut zwischen zwei Tabellen wechseln download
Wert in Zwischenablage suchen download Eingabekontrolle bei Datumswerten download