Formel Bezug Fehler

Bild

Betrifft: Formel Bezug Fehler
von: Thorsten
Geschrieben am: 30.09.2003 10:26:14

Hi,

mittels eines makros fülle ich einen Zellbereich aus. Für eine Saplte dieses dieses Bereiches möchte ich nun Herausfindnen, wie oft der Wert ja auftaucht.
Dafür habe ich eine andere Zelle (die nicht von dem makro beinflusst wird) mit der Formel:
=ZÄHLENWENN(M17:M127;"ja")versehen. Allerdings bekomme ich dann beim Füllen des makros dann die Fehelermekdung #Bezug!...

Wie kann ich das verhindern so dass ich nach auffüllen der Zellen dann die Anzhal der Zellen mit "ja" erhalte?

Danke im voraus

Bild


Betrifft: AW: Formel Bezug Fehler
von: Reinhard
Geschrieben am: 30.09.2003 10:43:09

Hallo Thorsten,
ich kriege da keinen Bezugs-Fehler...
Gruß
Reinhard
ps: weiß jemand warum die Formula-Anweisung einen Fehler egibt?, jedenfalls in B1 steht die dort genannte Formel drin und zeigt korrekt an.

Sub test()
'Range("b1").Formula = "=ZÄHLENWENN(a1:a10;"ja")"
For n = 1 To 10
     x = Int((2 * Rnd) + 1)
     Cells(n, 1) = "nein"
     If x = 2 Then Cells(n, 1) = "ja"
Next n
End Sub



Bild


Betrifft: AW: Formel Bezug Fehler
von: BerndE
Geschrieben am: 30.09.2003 10:47:41

Hallo Reinhard,

der Fehler ergibt sich evtl. daraus, dass 'Zählenwenn' die deutsche Bezeichnung ist. Wahrscheinlich muss hier die englische verwendet werden...

Gruß
Bernd

www.bernds.page.de.vu


Bild


Betrifft: AW: Formel Bezug Fehler
von: Mac4
Geschrieben am: 30.09.2003 10:48:57

Hallo Reinhard,

wenn Du die deutsche Bezeichnung der Formel (Zählenwenn) in Deiner Formel benutzt, musst Du mit FormulaLocal arbeiten.
Bei Formula brauchst Du die englischen Bezeichnung (Countif)

Marc


Bild


Betrifft: AW: Formel Bezug Fehler
von: Thorsten
Geschrieben am: 30.09.2003 11:02:33

Hi,

kann das eventuell daran liegen, das der Bereich zuvor von dem Makro gelöscht wird?? Aber auch dann verstehe ich das nicht so ganz, da die Zellbezüge sich doch eigentlich nicht ändern...


Bild


Betrifft: Merci o.w.T.
von: Reinhard
Geschrieben am: 30.09.2003 12:07:41

.


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Formel Bezug Fehler"