Microsoft Excel

Herbers Excel/VBA-Archiv

Dienstplanerstellung

    Betrifft: Dienstplanerstellung von: Jens
    Geschrieben am: 02.10.2003 22:34:24

    Bin leider ziemlich unbeleckt in sachen Excel, daher auch eine für den einen oder anderen möglicherweise banale Frage:

    Bei einer Dienstplanerstellung möchte ich Kürzel wie "N" oder "W" in die Tabelle für die verschiedenen Dienstzeiten (z.B. Nacht oder Wochenende) eingeben.
    Irgendwie muß es doch möglich sein diese Kürzel mit einem Zahlenwert (Stundenanzahl) zu verknüpfen, die dann pro Spalte summiert werden ohne daß diese Zahlenwerte in den einzelnen Zellen erscheinen. Lediglich die Summe sollte dann unten erscheinen. Also Buchstabe als Platzhalter für Zahl, mit der im Hintergrund gerechnet wird.

    Kann mir jemand helfen?

      


    Betrifft: AW: Dienstplanerstellung von: PeterW
    Geschrieben am: 02.10.2003 22:40:43

    Hallo Jens,

    schau dir in der Excel-Hilfe ZÄHLENWENN an, das löst dein Problem.

    Gruß
    Peter


      


    Betrifft: AW: Dienstplanerstellung von: Jens
    Geschrieben am: 03.10.2003 10:49:55

    Vielen Dank für den Tip. gruß Jens


      


    Betrifft: AW: Dienstplanerstellung von: Matthias G
    Geschrieben am: 02.10.2003 22:44:16

    Hallo Jens,
    angenommen, in Spalte A stehen in den Zeilen 1-10 die Dienste (N oder W), dann können ab Zeile 11 die Formeln:
    =ZÄHLENWENN(A1:A10;"N")*10 (10 Stunden Nachtdienst)
    =ZÄHLENWENN(A1:A10;"W")*8 (8 Stunden Wochenenddienst)
    ...stehen.
    oder gleich als Summe:
    = ZÄHLENWENN(A1:A10;"N")*10 + ZÄHLENWENN(A1:A10;"W")*8

    Gruß,
    Matthias


      


    Betrifft: AW: Dienstplanerstellung von: Jens
    Geschrieben am: 03.10.2003 10:51:24

    Das ist genau das was ich suche! Vielen Dank Gruß Jens


      


    Betrifft: AW: Dienstplanerstellung von: th.heinrich
    Geschrieben am: 02.10.2003 22:46:55

    hallo Jens,

    das mit den dienstplaenen wird hier des oefteren behandelt. problem ist dabei immer, dass der TABELLENAUFBAU immer anders ist.

    suche ueber GOOGLE unter diesem suchbegriff "Dienstplan" site:www.herber.de

    warum nicht als SPALTENÜBERSCHRIFTEN N u. W dann ist summieren kein prob.

    gruss thomas


      


    Betrifft: AW: Dienstplanerstellung von: Jens
    Geschrieben am: 03.10.2003 10:53:58

    Probier ich mal aus. danke Jens


      


    Betrifft: danke fuer die rueckmeldung ot. von: th.heinrich
    Geschrieben am: 03.10.2003 14:11:36

    .